summaryrefslogtreecommitdiff
path: root/media-libs
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/Manifest.gzbin69202 -> 69202 bytes
-rw-r--r--media-libs/compface/Manifest2
-rw-r--r--media-libs/compface/compface-1.5.2-r1.ebuild31
-rw-r--r--media-libs/compface/files/compface-modern-c-porting.patch515
-rw-r--r--media-libs/libvpx/Manifest2
-rw-r--r--media-libs/libvpx/libvpx-1.13.1.ebuild2
6 files changed, 550 insertions, 2 deletions
diff --git a/media-libs/Manifest.gz b/media-libs/Manifest.gz
index 136d1c636fe7..562a9b443f1a 100644
--- a/media-libs/Manifest.gz
+++ b/media-libs/Manifest.gz
Binary files differ
diff --git a/media-libs/compface/Manifest b/media-libs/compface/Manifest
index bc0c77513936..3e65af866d0f 100644
--- a/media-libs/compface/Manifest
+++ b/media-libs/compface/Manifest
@@ -1,4 +1,6 @@
AUX compface-gentoo.patch 1415 BLAKE2B cac49f8b6cb2680df1ef46a811a3dfaf1f7c170b69f3eeb91daa784e885fd75925169a85e6716944056b9f0fa4d29df96c795c3d16f1a1b89d54468faf555c17 SHA512 e966f02c7566a657751ad4ecd30805c5cb77e9fd76a458d639ff3291d0bd3c4e886bfc37106a755b1387c5ceee331eee1921595249e07175918bb218cd449a10
+AUX compface-modern-c-porting.patch 8123 BLAKE2B db65f7854886637ee990bce3d3b46e57af7da0e21e43267cac8dc59bb20fb09b04ed77939631ceeb594029b0be0823965e67a7be52efd462490067addbc107a5 SHA512 a8f8b2d4be269c7a1135394aee9d0d65323fc54db21a73a085c6a50b7659d172f20a9ecf397443292c40ebefd059b3caed2c843b301d9d37f3a31472822e0e85
DIST compface-1.5.2.tar.gz 46970 BLAKE2B d26c25a35b3a2e63ddfb50feace61930fa3be9f4150ad8f8c96a3820ccebf1422fda5703628d58ad646f1d1eeaccc5f2f08ed5f2e74b845f5d7328f2829e63d6 SHA512 0da9ee4c5fb2b5c712466d9fa6170e5687b23c038e6304baa42d7ede6d9bd50a1b84da416eb853a420c01a6b9eccd5e7d92a4ebc26295714b85254c05c9e3360
+EBUILD compface-1.5.2-r1.ebuild 672 BLAKE2B 81f426ef10babdfaf974657b573f899eca46f0e6f8845d10b540be3a95345d045e54d80a75a43c1af9336ad81ea9918b53aad33b71fb7956498e5d94047b0a49 SHA512 b8ee00fbe66fb561b9e892f9a92dd9b474437c4436e8c83212d45947189ec3efa01a5e80345eb5978e075513eb72b26bde4fbe4379cb080c54178ef8a12ae675
EBUILD compface-1.5.2.ebuild 620 BLAKE2B 445cf51de262bbd945e747b196d500a3d959cfd24edad59f15595f1d1181352bd503c5512366b9d5ea606258bbd9a85165cdf21b6b597b5424dffabcbee79835 SHA512 461b140c9979c1c83d8288d0edfdd16bd1631c19a8d97c206a7f8a484713974ad46110b091940160843697466c794f7634ba1cfbf7db603ed6072643eb87ee3a
MISC metadata.xml 249 BLAKE2B a37da98d387308dab889eab2665b67e4176707f3c115a7a69cb7f4b19f9864b96bc2fe70efa105e627c4b57a7d626f6b23dc2709a225a9debada3356f3cf32a0 SHA512 a5095fb01e05f24583a962e36131b2f02cf2d1dd7a97051200e465ad97db014721de7c1857f5eb736cb0290682e8de833cb4c735f7de8d98cdfae1aed6d3d549
diff --git a/media-libs/compface/compface-1.5.2-r1.ebuild b/media-libs/compface/compface-1.5.2-r1.ebuild
new file mode 100644
index 000000000000..4577e34db17b
--- /dev/null
+++ b/media-libs/compface/compface-1.5.2-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit autotools
+
+DESCRIPTION="Utilities and library to convert to/from X-Face format"
+HOMEPAGE="http://www.xemacs.org/Download/optLibs.html"
+SRC_URI="http://ftp.xemacs.org/pub/xemacs/aux/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+RDEPEND="dev-lang/perl"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-gentoo.patch
+ "${FILESDIR}"/${PN}-modern-c-porting.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+ newbin xbm2xface{.pl,}
+}
diff --git a/media-libs/compface/files/compface-modern-c-porting.patch b/media-libs/compface/files/compface-modern-c-porting.patch
new file mode 100644
index 000000000000..bc29be071240
--- /dev/null
+++ b/media-libs/compface/files/compface-modern-c-porting.patch
@@ -0,0 +1,515 @@
+diff --git a/arith.c b/arith.c
+index 784946f..a4dd9df 100644
+--- a/arith.c
++++ b/arith.c
+@@ -20,8 +20,7 @@
+ #include "compface.h"
+
+ void
+-RevPush(p)
+-Prob *p;
++RevPush(Prob *p)
+ {
+ if (NumProbs >= PIXELS * 2 - 1)
+ longjmp(comp_env, ERR_INTERNAL);
+@@ -29,8 +28,7 @@ Prob *p;
+ }
+
+ void
+-BigPush(p)
+-Prob *p;
++BigPush(Prob *p)
+ {
+ static WORD tmp;
+
+@@ -40,11 +38,10 @@ Prob *p;
+ }
+
+ int
+-BigPop(p)
+-register Prob *p;
++BigPop(Prob *p)
+ {
+ static WORD tmp;
+- register int i;
++ int i;
+
+ BigDiv(0, &tmp);
+ i = 0;
+@@ -61,11 +58,11 @@ register Prob *p;
+ #ifdef DEBUG
+ /* Print a BigInt in HexaDecimal
+ */
+-void
+-BigPrint()
++void
++BigPrint (void)
+ {
+- register int i, c, count;
+- register WORD *w;
++ int i, c, count;
++ WORD *w;
+
+ count = 0;
+ w = B.b_word + (i = B.b_words);
+@@ -91,12 +88,11 @@ BigPrint()
+ * pointer to by r
+ */
+ void
+-BigDiv(a, r)
+-register WORD a, *r;
++BigDiv(WORD a, WORD *r)
+ {
+- register int i;
+- register WORD *w;
+- register COMP c, d;
++ int i;
++ WORD *w;
++ COMP c, d;
+
+ a &= WORDMASK;
+ if ((a == 1) || (B.b_words == 0))
+@@ -135,12 +131,11 @@ register WORD a, *r;
+ /* Multiply a by B storing the result in B
+ */
+ void
+-BigMul(a)
+-register WORD a;
++BigMul(WORD a)
+ {
+- register int i;
+- register WORD *w;
+- register COMP c;
++ int i;
++ WORD *w;
++ COMP c;
+
+ a &= WORDMASK;
+ if ((a == 1) || (B.b_words == 0))
+@@ -179,12 +174,11 @@ register WORD a;
+ /* Subtract a from B storing the result in B
+ */
+ void
+-BigSub(a)
+-WORD a;
++BigSub(WORD a)
+ {
+- register int i;
+- register WORD *w;
+- register COMP c;
++ int i;
++ WORD *w;
++ COMP c;
+
+ a &= WORDMASK;
+ if (a == 0)
+@@ -209,12 +203,11 @@ WORD a;
+ /* Add to a to B storing the result in B
+ */
+ void
+-BigAdd(a)
+-WORD a;
++BigAdd(WORD a)
+ {
+- register int i;
+- register WORD *w;
+- register COMP c;
++ int i;
++ WORD *w;
++ COMP c;
+
+ a &= WORDMASK;
+ if (a == 0)
+@@ -237,8 +230,8 @@ WORD a;
+ }
+ }
+
+-void
+-BigClear()
++void
++BigClear (void)
+ {
+ B.b_words = 0;
+ }
+diff --git a/cmain.c b/cmain.c
+index ec0558d..2a95bc2 100644
+--- a/cmain.c
++++ b/cmain.c
+@@ -61,9 +61,7 @@ char *strerrorwrap();
+ #define WARN {(void)strcat(fbuf, "\n"); (void)write(2, fbuf, strlen(fbuf));}
+
+ int
+-main(argc, argv)
+-int argc;
+-char *argv[];
++main(int argc, char **argv)
+ {
+ cmdname = *argv;
+ while (**argv)
+@@ -121,11 +119,11 @@ char *argv[];
+ }
+
+
+-int
+-WriteBuf()
++int
++WriteBuf (void)
+ {
+- register char *s, *t;
+- register int len;
++ char *s, *t;
++ int len;
+
+ s = fbuf;
+ t = s + strlen(s);
+@@ -144,15 +142,15 @@ WriteBuf()
+ }
+
+
+-int
+-ReadBuf()
++int
++ReadBuf (void)
+ {
+- register int count, len;
+- register char *t;
++ int count, len;
++ char *t;
+
+ count = 0;
+ t = fbuf;
+- while (len = read(infile, t, FACEBUFLEN - count))
++ while ((len = read(infile, t, FACEBUFLEN - count)))
+ {
+ if (len == -1)
+ {
+@@ -175,8 +173,7 @@ ReadBuf()
+ }
+
+ #ifdef HAVE_STRERROR
+-char *strerrorwrap(err)
+-int err;
++char *strerrorwrap(int err)
+ {
+ char *c = strerror(err);
+ return ((c) ? (c) : "" );
+diff --git a/compface.c b/compface.c
+index 90664c4..b1b00a8 100644
+--- a/compface.c
++++ b/compface.c
+@@ -22,8 +22,7 @@
+ #include "compface_private.h"
+
+ int
+-compface(fbuf)
+-char *fbuf;
++compface(char *fbuf)
+ {
+ if (!(status = setjmp(comp_env)))
+ {
+diff --git a/compface.h b/compface.h
+index fc4f486..23ae426 100644
+--- a/compface.h
++++ b/compface.h
+@@ -17,6 +17,7 @@
+ #define COMPFACE_H
+
+ #include <setjmp.h>
++#include <unistd.h>
+
+ /* For all function declarations, if ANSI then use a prototype. */
+
+diff --git a/compress.c b/compress.c
+index 3c97806..6f22e17 100644
+--- a/compress.c
++++ b/compress.c
+@@ -21,12 +21,10 @@
+ #include "compface.h"
+
+ int
+-Same(f, wid, hei)
+-register char *f;
+-register int wid, hei;
++Same(char *f, int wid, int hei)
+ {
+- register char val, *row;
+- register int x;
++ char val, *row;
++ int x;
+
+ val = *f;
+ while (hei--)
+@@ -42,9 +40,7 @@ register int wid, hei;
+ }
+
+ int
+-AllBlack(f, wid, hei)
+-char *f;
+-int wid, hei;
++AllBlack(char *f, int wid, int hei)
+ {
+ if (wid > 3)
+ {
+@@ -59,17 +55,13 @@ int wid, hei;
+ }
+
+ int
+-AllWhite(f, wid, hei)
+-char *f;
+-int wid, hei;
++AllWhite(char *f, int wid, int hei)
+ {
+ return ((*f == 0) && Same(f, wid, hei));
+ }
+
+ void
+-PopGreys(f, wid, hei)
+-char *f;
+-int wid, hei;
++PopGreys(char *f, int wid, int hei)
+ {
+ if (wid > 3)
+ {
+@@ -95,9 +87,7 @@ int wid, hei;
+ }
+
+ void
+-PushGreys(f, wid, hei)
+-char *f;
+-int wid, hei;
++PushGreys(char *f, int wid, int hei)
+ {
+ if (wid > 3)
+ {
+@@ -114,9 +104,7 @@ int wid, hei;
+ }
+
+ void
+-UnCompress(f, wid, hei, lev)
+-register char *f;
+-register int wid, hei, lev;
++UnCompress(char *f, int wid, int hei, int lev)
+ {
+ switch (BigPop(&levels[lev][0]))
+ {
+@@ -138,9 +126,7 @@ register int wid, hei, lev;
+ }
+
+ void
+-Compress(f, wid, hei, lev)
+-register char *f;
+-register int wid, hei, lev;
++Compress(char *f, int wid, int hei, int lev)
+ {
+ if (AllWhite(f, wid, hei))
+ {
+@@ -164,10 +150,9 @@ register int wid, hei, lev;
+ }
+
+ void
+-UnCompAll(fbuf)
+-char *fbuf;
++UnCompAll(char *fbuf)
+ {
+- register char *p;
++ char *p;
+
+ BigClear();
+ BigRead(fbuf);
+@@ -186,8 +171,7 @@ char *fbuf;
+ }
+
+ void
+-CompAll(fbuf)
+-char *fbuf;
++CompAll(char *fbuf)
+ {
+ Compress(F, 16, 16, 0);
+ Compress(F + 16, 16, 16, 0);
+diff --git a/file.c b/file.c
+index 3a3809e..c69f5b5 100644
+--- a/file.c
++++ b/file.c
+@@ -23,10 +23,9 @@
+ int compface_xbitmap=0;
+
+ void
+-BigRead(fbuf)
+-register char *fbuf;
++BigRead(char *fbuf)
+ {
+- register int c;
++ int c;
+
+ while (*fbuf != '\0')
+ {
+@@ -39,13 +38,12 @@ register char *fbuf;
+ }
+
+ void
+-BigWrite(fbuf)
+-register char *fbuf;
++BigWrite(char *fbuf)
+ {
+ static WORD tmp;
+ static char buf[DIGITS];
+- register char *s;
+- register int i;
++ char *s;
++ int i;
+
+ s = buf;
+ while (B.b_words > 0)
+@@ -72,11 +70,10 @@ register char *fbuf;
+ }
+
+ void
+-ReadFace(fbuf)
+-char *fbuf;
++ReadFace(char *fbuf)
+ {
+- register int c, i;
+- register char *s, *t;
++ int c, i;
++ char *s, *t;
+
+ t = s = fbuf;
+ for(i = strlen(s); i > 0; i--)
+@@ -129,11 +126,10 @@ char *fbuf;
+ }
+
+ void
+-WriteFace(fbuf)
+-char *fbuf;
++WriteFace(char *fbuf)
+ {
+- register char *s, *t;
+- register int i, bits, digits, words;
++ char *s, *t;
++ int i, bits, digits, words;
+ int digsperword = DIGSPERWORD;
+ int wordsperline = WORDSPERLINE;
+
+diff --git a/gen.c b/gen.c
+index 4dedc09..1b99536 100644
+--- a/gen.c
++++ b/gen.c
+@@ -25,10 +25,9 @@
+ static void Gen P((char *)) ;
+
+ static void
+-Gen(f)
+-register char *f;
++Gen(char *f)
+ {
+- register int m, l, k, j, i, h;
++ int m, l, k, j, i, h;
+
+ for (j = 0; j < HEIGHT; j++)
+ {
+@@ -91,13 +90,13 @@ register char *f;
+ }
+ }
+
+-void
+-GenFace()
++void
++GenFace (void)
+ {
+ static char new[PIXELS];
+- register char *f1;
+- register char *f2;
+- register int i;
++ char *f1;
++ char *f2;
++ int i;
+
+ f1 = new;
+ f2 = F;
+@@ -107,8 +106,8 @@ GenFace()
+ Gen(new);
+ }
+
+-void
+-UnGenFace()
++void
++UnGenFace (void)
+ {
+ Gen(F);
+ }
+diff --git a/uncmain.c b/uncmain.c
+index a94279d..52d3173 100644
+--- a/uncmain.c
++++ b/uncmain.c
+@@ -57,9 +57,7 @@ char *strerrorwrap(int err);
+ #define WARN {(void)strcat(fbuf, "\n"); (void)write(2, fbuf, strlen(fbuf));}
+
+ int
+-main(argc, argv)
+-int argc;
+-char *argv[];
++main(int argc, char **argv)
+ {
+ cmdname = *argv;
+ while (**argv)
+@@ -124,11 +122,11 @@ char *argv[];
+ }
+
+
+-int
+-WriteBuf()
++int
++WriteBuf (void)
+ {
+- register char *s, *t;
+- register int len;
++ char *s, *t;
++ int len;
+
+ s = fbuf;
+ t = s + strlen(s);
+@@ -147,15 +145,15 @@ WriteBuf()
+ }
+
+
+-int
+-ReadBuf()
++int
++ReadBuf (void)
+ {
+- register int count, len;
+- register char *t;
++ int count, len;
++ char *t;
+
+ count = 0;
+ t = fbuf;
+- while (len = read(infile, t, FACEBUFLEN - count))
++ while ((len = read(infile, t, FACEBUFLEN - count)))
+ {
+ if (len == -1)
+ {
+@@ -178,8 +176,7 @@ ReadBuf()
+ }
+
+ #ifdef HAVE_STRERROR
+-char *strerrorwrap(err)
+-int err;
++char *strerrorwrap(int err)
+ {
+ char *c = strerror(err);
+ return ((c) ? (c) : "" );
+diff --git a/uncompface.c b/uncompface.c
+index 1a61eb5..d41f9bc 100644
+--- a/uncompface.c
++++ b/uncompface.c
+@@ -23,8 +23,7 @@
+ #include "compface_private.h"
+
+ int
+-uncompface(fbuf)
+-char *fbuf;
++uncompface(char *fbuf)
+ {
+ if (!(status = setjmp(comp_env)))
+ {
diff --git a/media-libs/libvpx/Manifest b/media-libs/libvpx/Manifest
index f191f9601d23..3781debe9304 100644
--- a/media-libs/libvpx/Manifest
+++ b/media-libs/libvpx/Manifest
@@ -11,5 +11,5 @@ DIST libvpx-testdata-1.13.1.tar.xz 495765552 BLAKE2B 4aba008653b645c1adbfc0f4e20
EBUILD libvpx-1.12.0-r1.ebuild 4298 BLAKE2B cf4d4610f3ded71551126030e2b46a0e79aa2d0409621f4f7501f1b6f69facec0173c7d9b5b0f5391ac80cb4e797765225cd5326bb00ef52dc1dfb26e1e2ae2d SHA512 7773a3927a9355b855aa9ab43cb162f32b1661d670b36077e685d5bbbf2e0a8b7a2ced7ead593ceb4133261f2fa50ad345f74b939e7625384f57bedbeb7a568b
EBUILD libvpx-1.13.0-r1.ebuild 4372 BLAKE2B 198687a4c6fabe36155c1914b994d676ca89c45aa4561ac99c3fdbacf2134b9b417008d7d527e2a21e6c7c8d4a8232e4cf303c9bd86dfb1476359f94896ec808 SHA512 b2a683ce0fcd8dfac1b61438439cf4538072930ae763a91aff59d7c8888d68afc4fc1908fe257809fab10f8eae60564347d9c49f30bf54a281e600bfdda84805
EBUILD libvpx-1.13.0.ebuild 4220 BLAKE2B 090cfb41d4efa2475a636aee90d12c8636d84ff02aaf4589ab19248dcc4ac4ac920d2640e89dc35e342dd6754878a67721ca637f650d9149a7640c72ff51da16 SHA512 8d781d69c1c82e582b4f57f2441d503b4b9c148584344ee791a76b0eba8ccf0cf159a00826adca2402f1aac76a75d4764348710f13421c8f8eed6b0807036d36
-EBUILD libvpx-1.13.1.ebuild 4225 BLAKE2B 11c343bf20c74b09957c01eb13917f7a896b0e81c682d5cae151ba6512eb11082e83c439dd177d7b8daba2a7ace97a078c51b0386a0ad0b31b8c6c5fba8069e5 SHA512 8fc834b8d64ac077a8d93463e46ad00d11c6c0d2b6690ce67899dadf7a26d1e624cd6de0b9ac30ab6167ca4a6dd0371281268195b6b7abcdf930610d741a36e3
+EBUILD libvpx-1.13.1.ebuild 4220 BLAKE2B 00e6912d99e551a16141d9edc09ba2631189e40371c2523e5791b6262ba037857be05ab82d98fd7d300285b31d97e904f340d740e7040ee86a6bc20b76497cd3 SHA512 7b66edfec367033ef1ac4b254c7989b3ded86d1b5b0cb4d9841e3d029b331aa414c0c8554815c22185b0bb9c871b480b0020b797e6c6e420c2db8c3cef8151e6
MISC metadata.xml 655 BLAKE2B 00bcc63009898b794c7e142cd83096f779758e0d5ce274d10f97cc08f4b98f929719c01898d64137aa125c7628bb991fb128d07a490e7e7b029be6f1041e28ac SHA512 0d2dd46ed564109ca5cd841b41ccc30ddb45e5c0e416624b7e8c0895d67217cfcc71cba0d13ab96af2a898add5f1cf8feb44b6a015ff8487668055c0f288e9fc
diff --git a/media-libs/libvpx/libvpx-1.13.1.ebuild b/media-libs/libvpx/libvpx-1.13.1.ebuild
index f383dae1d20f..e92de1ca22a6 100644
--- a/media-libs/libvpx/libvpx-1.13.1.ebuild
+++ b/media-libs/libvpx/libvpx-1.13.1.ebuild
@@ -24,7 +24,7 @@ SRC_URI="
LICENSE="BSD"
SLOT="0/8"
-KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+KEYWORDS="amd64 arm arm64 ~ia64 ~loong ~ppc ppc64 ~riscv ~s390 ~sparc x86 ~amd64-linux ~x86-linux"
IUSE="cpu_flags_ppc_vsx3 doc +highbitdepth postproc static-libs test +threads"
REQUIRED_USE="test? ( threads )"
RESTRICT="!test? ( test )"