summaryrefslogtreecommitdiff
path: root/media-libs/x265/files/arm.patch
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/x265/files/arm.patch')
-rw-r--r--media-libs/x265/files/arm.patch34
1 files changed, 0 insertions, 34 deletions
diff --git a/media-libs/x265/files/arm.patch b/media-libs/x265/files/arm.patch
deleted file mode 100644
index 69edcdecfb91..000000000000
--- a/media-libs/x265/files/arm.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-More aliases for ARM.
-Do not force CFLAGS for ARM.
-
-Index: source/CMakeLists.txt
-===================================================================
---- source.orig/CMakeLists.txt
-+++ source/CMakeLists.txt
-@@ -41,7 +41,7 @@ SET(CMAKE_MODULE_PATH "${PROJECT_SOURCE_
- # System architecture detection
- string(TOLOWER "${CMAKE_SYSTEM_PROCESSOR}" SYSPROC)
- set(X86_ALIASES x86 i386 i686 x86_64 amd64)
--set(ARM_ALIASES armv6l armv7l)
-+set(ARM_ALIASES armv6l armv6j armv7l armv7a)
- list(FIND X86_ALIASES "${SYSPROC}" X86MATCH)
- list(FIND ARM_ALIASES "${SYSPROC}" ARMMATCH)
- set(POWER_ALIASES ppc64 ppc64le)
-@@ -208,15 +208,11 @@ if(GCC)
- endif()
- endif()
- endif()
-- if(ARM AND CROSS_COMPILE_ARM)
-- set(ARM_ARGS -march=armv6 -mfloat-abi=soft -mfpu=vfp -marm -fPIC)
-- elseif(ARM)
-+ if(ARM)
- find_package(Neon)
- if(CPU_HAS_NEON)
-- set(ARM_ARGS -mcpu=native -mfloat-abi=hard -mfpu=neon -marm -fPIC)
-+ set(ARM_ARGS -mfpu=neon)
- add_definitions(-DHAVE_NEON)
-- else()
-- set(ARM_ARGS -mcpu=native -mfloat-abi=hard -mfpu=vfp -marm)
- endif()
- endif()
- add_definitions(${ARM_ARGS})