summaryrefslogtreecommitdiff
path: root/media-libs/woff2/woff2-1.0.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/woff2/woff2-1.0.2.ebuild')
-rw-r--r--media-libs/woff2/woff2-1.0.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/media-libs/woff2/woff2-1.0.2.ebuild b/media-libs/woff2/woff2-1.0.2.ebuild
new file mode 100644
index 000000000000..36a44eb0c5bf
--- /dev/null
+++ b/media-libs/woff2/woff2-1.0.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Encode/decode WOFF2 font format"
+HOMEPAGE="https://github.com/google/woff2"
+SRC_URI="https://github.com/google/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="app-arch/brotli"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local mycmakeargs=(
+ # needed, causes QA warnings otherwise
+ -DCMAKE_SKIP_RPATH=ON
+ )
+ cmake-utils_src_configure
+}