summaryrefslogtreecommitdiff
path: root/media-libs/vulkan-loader/vulkan-loader-1.1.70.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/vulkan-loader/vulkan-loader-1.1.70.0-r1.ebuild')
-rw-r--r--media-libs/vulkan-loader/vulkan-loader-1.1.70.0-r1.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/media-libs/vulkan-loader/vulkan-loader-1.1.70.0-r1.ebuild b/media-libs/vulkan-loader/vulkan-loader-1.1.70.0-r1.ebuild
new file mode 100644
index 000000000000..980db94c32fb
--- /dev/null
+++ b/media-libs/vulkan-loader/vulkan-loader-1.1.70.0-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/KhronosGroup/Vulkan-LoaderAndValidationLayers.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/KhronosGroup/Vulkan-LoaderAndValidationLayers/archive/sdk-${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/Vulkan-LoaderAndValidationLayers-sdk-${PV}"
+fi
+
+inherit python-any-r1 cmake-multilib
+
+DESCRIPTION="Vulkan Installable Client Driver (ICD) Loader"
+HOMEPAGE="https://github.com/KhronosGroup/Vulkan-LoaderAndValidationLayers"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="demos layers wayland X"
+REQUIRED_USE="demos? ( X )"
+
+RDEPEND=""
+DEPEND="${PYTHON_DEPS}
+ demos? ( dev-util/glslang:=[${MULTILIB_USEDEP}] )
+ layers? (
+ dev-util/glslang:=[${MULTILIB_USEDEP}]
+ >=dev-util/spirv-tools-2018.2-r1:=[${MULTILIB_USEDEP}]
+ )
+ wayland? ( dev-libs/wayland:=[${MULTILIB_USEDEP}] )
+ X? (
+ x11-libs/libX11:=[${MULTILIB_USEDEP}]
+ x11-libs/libXrandr:=[${MULTILIB_USEDEP}]
+ )"
+
+PATCHES=(
+ "${FILESDIR}/${P}-Dont-require-glslang-if-not-building-layers.patch"
+ "${FILESDIR}/${PN}-Fix-layers-install-directory.patch"
+ "${FILESDIR}/${PN}-Use-a-file-to-get-the-spirv-tools-commit-ID.patch"
+ )
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_SKIP_RPATH=True
+ -DBUILD_TESTS=False
+ -DBUILD_LAYERS=$(usex layers)
+ -DBUILD_DEMOS=$(usex demos)
+ -DBUILD_VKJSON=False
+ -DBUILD_LOADER=True
+ -DBUILD_WSI_MIR_SUPPORT=False
+ -DBUILD_WSI_WAYLAND_SUPPORT=$(usex wayland)
+ -DBUILD_WSI_XCB_SUPPORT=$(usex X)
+ -DBUILD_WSI_XLIB_SUPPORT=$(usex X)
+ )
+ cmake-utils_src_configure
+}
+
+multilib_src_install() {
+ keepdir /etc/vulkan/icd.d
+
+ cmake-utils_src_install
+}