summaryrefslogtreecommitdiff
path: root/media-libs/vigra/vigra-1.11.1-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/vigra/vigra-1.11.1-r3.ebuild')
-rw-r--r--media-libs/vigra/vigra-1.11.1-r3.ebuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/media-libs/vigra/vigra-1.11.1-r3.ebuild b/media-libs/vigra/vigra-1.11.1-r3.ebuild
index 93a26b7b05e2..c9dfc49eed8e 100644
--- a/media-libs/vigra/vigra-1.11.1-r3.ebuild
+++ b/media-libs/vigra/vigra-1.11.1-r3.ebuild
@@ -5,7 +5,7 @@ EAPI=7
PYTHON_COMPAT=( python3_{6,7,8} )
PYTHON_REQ_USE="threads(+),xml"
-inherit cmake-utils python-r1
+inherit cmake python-r1
DESCRIPTION="C++ computer vision library emphasizing customizable algorithms and structures"
HOMEPAGE="https://ukoethe.github.io/vigra/"
@@ -62,6 +62,7 @@ PATCHES=(
"${FILESDIR}/${P}-fix-incorrect-template-parameter-type.patch"
"${FILESDIR}/${P}-boost-python.patch"
"${FILESDIR}/${P}-python3.7.patch" # bug 701208
+ "${FILESDIR}/${P}-gcc-10.patch" # bug 723302
# TODO: upstream
"${FILESDIR}/${P}-lib_suffix.patch"
"${FILESDIR}/${P}-cmake-module-dir.patch"
@@ -80,7 +81,7 @@ src_prepare() {
fi
}
- cmake-utils_src_prepare
+ cmake_src_prepare
vigra_disable fftw fftw3
vigra_disable fftw fftw3f
@@ -110,7 +111,7 @@ src_configure() {
-DWITH_VALGRIND=$(usex valgrind)
-DWITH_VIGRANUMPY=$(usex python)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
if use python; then
@@ -123,7 +124,7 @@ src_configure() {
src_compile() {
local VIGRA_BUILD_DIR
vigra_compile() {
- cmake-utils_src_compile
+ cmake_src_compile
VIGRA_BUILD_DIR="${BUILD_DIR}"
}
if use python; then
@@ -135,17 +136,17 @@ src_compile() {
src_install() {
if use python; then
- python_foreach_impl cmake-utils_src_install
+ python_foreach_impl cmake_src_install
python_optimize
else
- cmake-utils_src_install
+ cmake_src_install
fi
}
src_test() {
# perhaps disable tests (see #390447)
vigra_test() {
- PYTHONPATH="${BUILD_DIR}/vigranumpy/vigra" cmake-utils_src_test
+ PYTHONPATH="${BUILD_DIR}/vigranumpy/vigra" cmake_src_test
}
if use python; then
python_foreach_impl vigra_test