summaryrefslogtreecommitdiff
path: root/media-libs/t1lib/files
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/t1lib/files')
-rw-r--r--media-libs/t1lib/files/t1lib-5.1.2-c99-configure.patch10
-rw-r--r--media-libs/t1lib/files/t1lib-5.1.2-c99.patch15
2 files changed, 25 insertions, 0 deletions
diff --git a/media-libs/t1lib/files/t1lib-5.1.2-c99-configure.patch b/media-libs/t1lib/files/t1lib-5.1.2-c99-configure.patch
new file mode 100644
index 000000000000..62a4df22a537
--- /dev/null
+++ b/media-libs/t1lib/files/t1lib-5.1.2-c99-configure.patch
@@ -0,0 +1,10 @@
+--- a/configure.in
++++ b/configure.in
+@@ -144,6 +144,7 @@ dnl We don'use
+ CFLAGS="$CFLAGS"
+ AC_CACHE_CHECK( "for gcc strength-reduce bug", ac_cv_c_gcc_strength_bug,
+ AC_TRY_RUN([
++#include <stdlib.h>
+ int main(void) {
+ static int Array[[3]];
+ unsigned int B = 3;
diff --git a/media-libs/t1lib/files/t1lib-5.1.2-c99.patch b/media-libs/t1lib/files/t1lib-5.1.2-c99.patch
new file mode 100644
index 000000000000..d1d3301fcc62
--- /dev/null
+++ b/media-libs/t1lib/files/t1lib-5.1.2-c99.patch
@@ -0,0 +1,15 @@
+https://src.fedoraproject.org/rpms/t1lib/blob/rawhide/f/t1lib-c99.patch
+
+Add missing parameter types for improved C99 compatibility: implicit
+ints are not part of C99.
+
+--- a/lib/type1/regions.c
++++ b/lib/type1/regions.c
+@@ -604,6 +604,7 @@
+ register struct region *R; /* region in which we are changing direction */
+ fractpel x,y; /* current beginning x,y */
+ fractpel dy; /* direction and magnitude of change in y */
++ int x2, y2;
+ {
+ register fractpel ymin,ymax; /* minimum and maximum Y since last call */
+ register fractpel x_at_ymin,x_at_ymax; /* their respective X's */