summaryrefslogtreecommitdiff
path: root/media-libs/svt-hevc/files
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/svt-hevc/files')
-rw-r--r--media-libs/svt-hevc/files/svt-hevc-1.5.1-dont-clobber-fortify_source.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/media-libs/svt-hevc/files/svt-hevc-1.5.1-dont-clobber-fortify_source.patch b/media-libs/svt-hevc/files/svt-hevc-1.5.1-dont-clobber-fortify_source.patch
new file mode 100644
index 000000000000..1cc2974b393c
--- /dev/null
+++ b/media-libs/svt-hevc/files/svt-hevc-1.5.1-dont-clobber-fortify_source.patch
@@ -0,0 +1,35 @@
+Don't clobber our toolchain defaults.
+
+https://bugs.gentoo.org/895260
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -100,7 +100,6 @@ set(flags_to_test
+ -Wformat-security
+ -fPIE
+ -fPIC
+- -D_FORTIFY_SOURCE=2
+ /GS
+ /sdl)
+ if(MSVC)
+--- a/gstreamer-plugin/CMakeLists.txt
++++ b/gstreamer-plugin/CMakeLists.txt
+@@ -25,8 +25,7 @@ set(flags_to_test
+ -fstack-protector-strong
+ -fPIE
+ -fPIC
+- -flto
+- -D_FORTIFY_SOURCE=2)
++ -flto)
+ if(NOT MSVC)
+ list(INSERT flags_to_test 0 -Wall)
+ else()
+--- a/gstreamer-plugin/meson.build
++++ b/gstreamer-plugin/meson.build
+@@ -22,7 +22,6 @@ svthevcenc_dep = dependency('SvtHevcEnc')
+ cc = meson.get_compiler('c')
+ cc_flags = [
+ '-O2',
+- '-D_FORTIFY_SOURCE=2',
+ '-Wformat',
+ '-Wformat-security',
+ '-fPIE',