summaryrefslogtreecommitdiff
path: root/media-libs/speexdsp/files/speexdsp-1.2_rc3-configure.patch
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/speexdsp/files/speexdsp-1.2_rc3-configure.patch')
-rw-r--r--media-libs/speexdsp/files/speexdsp-1.2_rc3-configure.patch44
1 files changed, 44 insertions, 0 deletions
diff --git a/media-libs/speexdsp/files/speexdsp-1.2_rc3-configure.patch b/media-libs/speexdsp/files/speexdsp-1.2_rc3-configure.patch
new file mode 100644
index 000000000000..ae29da58438b
--- /dev/null
+++ b/media-libs/speexdsp/files/speexdsp-1.2_rc3-configure.patch
@@ -0,0 +1,44 @@
+diff -Naur speexdsp-1.2rc3.orig/configure.ac speexdsp-1.2rc3/configure.ac
+--- speexdsp-1.2rc3.orig/configure.ac 2016-12-12 20:04:48.710853453 -0800
++++ speexdsp-1.2rc3/configure.ac 2016-12-12 20:05:07.588052415 -0800
+@@ -151,10 +151,17 @@
+ AC_ARG_ENABLE(sse, [ --enable-sse Enable SSE support], [
+ if test "x$enableval" != xno; then
+ has_sse=yes
+-has_sse2=yes
+-CFLAGS="$CFLAGS -O3 -msse -msse2"
++CFLAGS="$CFLAGS -msse"
+ else
+ has_sse=no
++fi
++])
++
++AC_ARG_ENABLE(sse2, [ --enable-sse2 Enable SSE2 support], [
++if test "x$enableval" != xno; then
++has_sse2=yes
++CFLAGS="$CFLAGS -msse2"
++else
+ has_sse2=no
+ fi
+ ])
+@@ -162,7 +169,7 @@
+ AC_ARG_ENABLE(neon, [ --enable-neon Enable NEON support], [
+ if test "x$enableval" != xno; then
+ has_neon=yes
+-CFLAGS="$CFLAGS -O3 -march=armv7-a -mfpu=neon"
++CFLAGS="$CFLAGS -mfpu=neon"
+ else
+ has_neon=no
+ fi
+diff -Naur speexdsp-1.2rc3.orig/libspeexdsp/Makefile.am speexdsp-1.2rc3/libspeexdsp/Makefile.am
+--- speexdsp-1.2rc3.orig/libspeexdsp/Makefile.am 2016-12-12 20:04:48.690853242 -0800
++++ speexdsp-1.2rc3/libspeexdsp/Makefile.am 2016-12-12 20:08:27.740161974 -0800
+@@ -29,7 +29,7 @@
+ pseudofloat.h smallft.h vorbis_psy.h resample_sse.h resample_neon.h
+
+ libspeexdsp_la_LDFLAGS = -no-undefined -version-info @SPEEXDSP_LT_CURRENT@:@SPEEXDSP_LT_REVISION@:@SPEEXDSP_LT_AGE@
+-libspeexdsp_la_LIBADD = $(LIBM)
++libspeexdsp_la_LIBADD = $(LIBM) $(FFT_LIBS)
+
+ if BUILD_EXAMPLES
+ noinst_PROGRAMS = testdenoise testecho testjitter testresample