summaryrefslogtreecommitdiff
path: root/media-libs/sdl-mixer/files
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/sdl-mixer/files')
-rw-r--r--media-libs/sdl-mixer/files/sdl-mixer-1.2.12-Fix-compiling-against-libmodplug-0.8.8.5.patch24
-rw-r--r--media-libs/sdl-mixer/files/sdl-mixer-1.2.12-clang.patch11
-rw-r--r--media-libs/sdl-mixer/files/sdl-mixer-1.2.12-incompatible-func-clang16.patch94
-rw-r--r--media-libs/sdl-mixer/files/sdl-mixer-1.2.12-mikmod-r587.patch55
-rw-r--r--media-libs/sdl-mixer/files/sdl-mixer-1.2.12-mikmod-r588.patch36
-rw-r--r--media-libs/sdl-mixer/files/sdl-mixer-1.2.12-parallel-build-slibtool.patch92
-rw-r--r--media-libs/sdl-mixer/files/sdl-mixer-1.2.12-wav.patch35
7 files changed, 0 insertions, 347 deletions
diff --git a/media-libs/sdl-mixer/files/sdl-mixer-1.2.12-Fix-compiling-against-libmodplug-0.8.8.5.patch b/media-libs/sdl-mixer/files/sdl-mixer-1.2.12-Fix-compiling-against-libmodplug-0.8.8.5.patch
deleted file mode 100644
index 369fe49558f0..000000000000
--- a/media-libs/sdl-mixer/files/sdl-mixer-1.2.12-Fix-compiling-against-libmodplug-0.8.8.5.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From: hasufell <hasufell@gentoo.org>
-Date: Fri, 8 Aug 2014 13:49:49 +0200
-Subject: [PATCH] Fix compiling against libmodplug-0.8.8.5
-
-pkg-config --cflags libmodplug no longer
-reports a subdir and thus we need to use
-#include "libmodplug/modplug.h" syntax.
----
- music_modplug.h | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
---- a/music_modplug.h
-+++ b/music_modplug.h
-@@ -1,6 +1,6 @@
- #ifdef MODPLUG_MUSIC
-
--#include "modplug.h"
-+#include "libmodplug/modplug.h"
- #include "SDL_rwops.h"
- #include "SDL_audio.h"
- #include "SDL_mixer.h"
---
-2.0.4
-
diff --git a/media-libs/sdl-mixer/files/sdl-mixer-1.2.12-clang.patch b/media-libs/sdl-mixer/files/sdl-mixer-1.2.12-clang.patch
deleted file mode 100644
index 3c462bd97088..000000000000
--- a/media-libs/sdl-mixer/files/sdl-mixer-1.2.12-clang.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- SDL_mixer-1.2.12.orig/music_mad.c
-+++ SDL_mixer-1.2.12/music_mad.c
-@@ -224,7 +224,7 @@
- if ((mp3_mad->status & MS_playing) == 0) {
- /* We're not supposed to be playing, so send silence instead. */
- memset(stream, 0, len);
-- return;
-+ return 0;
- }
-
- out = stream;
diff --git a/media-libs/sdl-mixer/files/sdl-mixer-1.2.12-incompatible-func-clang16.patch b/media-libs/sdl-mixer/files/sdl-mixer-1.2.12-incompatible-func-clang16.patch
deleted file mode 100644
index 747611880255..000000000000
--- a/media-libs/sdl-mixer/files/sdl-mixer-1.2.12-incompatible-func-clang16.patch
+++ /dev/null
@@ -1,94 +0,0 @@
-https://github.com/libsdl-org/SDL_mixer/commit/03bd4ca6aa38c1a382c892cef86296cd621ecc1d
-https://github.com/libsdl-org/SDL_mixer/commit/9e6d7b67a00656a68ea0c2eace75c587871549b9
-https://github.com/libsdl-org/SDL_mixer/commit/d28cbc34d63dd20b256103c3fe506ecf3d34d379
-https://github.com/libsdl-org/SDL_mixer/commit/05b12a3c22c0746c29dc5478f5b7fbd8a51a1303
-
-From 03bd4ca6aa38c1a382c892cef86296cd621ecc1d Mon Sep 17 00:00:00 2001
-From: Ozkan Sezer <sezeroz@gmail.com>
-Date: Sun, 7 Oct 2018 10:15:50 +0300
-Subject: [PATCH] backported a warning fix. (from 2.0 branch commit
- 6fa075aa693e).
-
----
- dynamic_ogg.h | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/dynamic_ogg.h b/dynamic_ogg.h
-index 822458d4..8eb91656 100644
---- a/dynamic_ogg.h
-+++ b/dynamic_ogg.h
-@@ -31,7 +31,7 @@ typedef struct {
- void *handle;
- int (*ov_clear)(OggVorbis_File *vf);
- vorbis_info *(*ov_info)(OggVorbis_File *vf,int link);
-- int (*ov_open_callbacks)(void *datasource, OggVorbis_File *vf, char *initial, long ibytes, ov_callbacks callbacks);
-+ int (*ov_open_callbacks)(void *datasource, OggVorbis_File *vf, const char *initial, long ibytes, ov_callbacks callbacks);
- ogg_int64_t (*ov_pcm_total)(OggVorbis_File *vf,int i);
- #ifdef OGG_USE_TREMOR
- long (*ov_read)(OggVorbis_File *vf,char *buffer,int length, int *bitstream);
-
-From 9e6d7b67a00656a68ea0c2eace75c587871549b9 Mon Sep 17 00:00:00 2001
-From: Ozkan Sezer <sezeroz@gmail.com>
-Date: Sun, 7 Oct 2018 12:41:20 +0300
-Subject: [PATCH] fixed a warning after commit cb08fb0976e6
-
---- a/dynamic_ogg.c
-+++ b/dynamic_ogg.c
-@@ -52,7 +52,7 @@ int Mix_InitOgg()
- return -1;
- }
- vorbis.ov_open_callbacks =
-- (int (*)(void *, OggVorbis_File *, char *, long, ov_callbacks))
-+ (int (*)(void *, OggVorbis_File *, const char *, long, ov_callbacks))
- SDL_LoadFunction(vorbis.handle, "ov_open_callbacks");
- if ( vorbis.ov_open_callbacks == NULL ) {
- SDL_UnloadObject(vorbis.handle);
-
-From d28cbc34d63dd20b256103c3fe506ecf3d34d379 Mon Sep 17 00:00:00 2001
-From: Ozkan Sezer <sezeroz@gmail.com>
-Date: Mon, 25 Nov 2019 03:28:02 +0300
-Subject: [PATCH] dynamic_ogg.c: fixed ov_time_seek() signature for
- libvorbisidec.
-
-reported by Vitaly Novichkov.
---- a/dynamic_ogg.c
-+++ b/dynamic_ogg.c
-@@ -78,7 +78,7 @@ int Mix_InitOgg()
- }
- vorbis.ov_time_seek =
- #ifdef OGG_USE_TREMOR
-- (long (*)(OggVorbis_File *,ogg_int64_t))
-+ (int (*)(OggVorbis_File *,ogg_int64_t))
- #else
- (int (*)(OggVorbis_File *,double))
- #endif
-
-
-From 05b12a3c22c0746c29dc5478f5b7fbd8a51a1303 Mon Sep 17 00:00:00 2001
-From: Ozkan Sezer <sezeroz@gmail.com>
-Date: Wed, 23 Sep 2020 05:32:00 +0300
-Subject: [PATCH] mixer.c: add missing dynamic_fluidsynth.h include -- fixes
- bug #5296.
-
----
- mixer.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/mixer.c b/mixer.c
-index c653d6ed..431f6e69 100644
---- a/mixer.c
-+++ b/mixer.c
-@@ -34,6 +34,7 @@
- #include "load_voc.h"
- #include "load_ogg.h"
- #include "load_flac.h"
-+#include "dynamic_fluidsynth.h"
- #include "dynamic_flac.h"
- #include "dynamic_mod.h"
- #include "dynamic_mp3.h"
-@@ -1499,4 +1500,3 @@ int Mix_UnregisterAllEffects(int channel)
- }
-
- /* end of mixer.c ... */
--
-
diff --git a/media-libs/sdl-mixer/files/sdl-mixer-1.2.12-mikmod-r587.patch b/media-libs/sdl-mixer/files/sdl-mixer-1.2.12-mikmod-r587.patch
deleted file mode 100644
index d99609f8ab25..000000000000
--- a/media-libs/sdl-mixer/files/sdl-mixer-1.2.12-mikmod-r587.patch
+++ /dev/null
@@ -1,55 +0,0 @@
-http://hg.libsdl.org/SDL_mixer/rev/56cad6484b04
-https://bugs.gentoo.org/445980
-
-# HG changeset patch
-# User Sam Lantinga <slouken@libsdl.org>
-# Date 1342998807 25200
-# Node ID 56cad6484b04f83c8d42428c755a046678506436
-# Parent c92001a2c18f628698c58aa4e05a7335d10d0e9e
-Paul P Komkoff Jr fixed malloc/free mismatch in the MikMod driver
-
---- a/dynamic_mod.c
-+++ b/dynamic_mod.c
-@@ -93,6 +93,13 @@
- SDL_UnloadObject(mikmod.handle);
- return -1;
- }
-+ mikmod.MikMod_free =
-+ (void (*)(void*))
-+ SDL_LoadFunction(mikmod.handle, "MikMod_free");
-+ if ( mikmod.MikMod_free == NULL ) {
-+ SDL_UnloadObject(mikmod.handle);
-+ return -1;
-+ }
- mikmod.Player_Active =
- (BOOL (*)(void))
- SDL_LoadFunction(mikmod.handle, "Player_Active");
---- a/dynamic_mod.h
-+++ b/dynamic_mod.h
-@@ -35,6 +35,7 @@
- void (*MikMod_RegisterDriver)(struct MDRIVER*);
- int* MikMod_errno;
- char* (*MikMod_strerror)(int);
-+ void (*MikMod_free)(void*);
- BOOL (*Player_Active)(void);
- void (*Player_Free)(MODULE*);
- MODULE* (*Player_LoadGeneric)(MREADER*,int,BOOL);
---- a/music_mod.c
-+++ b/music_mod.c
-@@ -109,13 +109,13 @@
-
- list = mikmod.MikMod_InfoDriver();
- if ( list )
-- free(list);
-+ mikmod.MikMod_free(list);
- else
- mikmod.MikMod_RegisterDriver(mikmod.drv_nos);
-
- list = mikmod.MikMod_InfoLoader();
- if ( list )
-- free(list);
-+ mikmod.MikMod_free(list);
- else
- mikmod.MikMod_RegisterAllLoaders();
-
-
diff --git a/media-libs/sdl-mixer/files/sdl-mixer-1.2.12-mikmod-r588.patch b/media-libs/sdl-mixer/files/sdl-mixer-1.2.12-mikmod-r588.patch
deleted file mode 100644
index d47a8d4534c8..000000000000
--- a/media-libs/sdl-mixer/files/sdl-mixer-1.2.12-mikmod-r588.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-http://hg.libsdl.org/SDL_mixer/rev/2ebb0d016f27
-https://bugs.gentoo.org/445980
-
-# HG changeset patch
-# User Sam Lantinga <slouken@libsdl.org>
-# Date 1343000017 25200
-# Node ID 2ebb0d016f277f7f643d8a66ed0e1099e10d1fba
-# Parent 56cad6484b04f83c8d42428c755a046678506436
-Fixed normal linking with libmikmod and linking with earlier versions of libmikmod.
-
---- a/dynamic_mod.c
-+++ b/dynamic_mod.c
-@@ -97,8 +97,8 @@
- (void (*)(void*))
- SDL_LoadFunction(mikmod.handle, "MikMod_free");
- if ( mikmod.MikMod_free == NULL ) {
-- SDL_UnloadObject(mikmod.handle);
-- return -1;
-+ /* libmikmod 3.1 and earlier doesn't have it */
-+ mikmod.MikMod_free = free;
- }
- mikmod.Player_Active =
- (BOOL (*)(void))
-@@ -246,6 +246,11 @@
- mikmod.MikMod_RegisterDriver = MikMod_RegisterDriver;
- mikmod.MikMod_errno = &MikMod_errno;
- mikmod.MikMod_strerror = MikMod_strerror;
-+#if LIBMIKMOD_VERSION < ((3<<16)|(2<<8))
-+ mikmod.MikMod_free = free;
-+#else
-+ mikmod.MikMod_free = MikMod_free;
-+#endif
- mikmod.Player_Active = Player_Active;
- mikmod.Player_Free = Player_Free;
- mikmod.Player_LoadGeneric = Player_LoadGeneric;
-
diff --git a/media-libs/sdl-mixer/files/sdl-mixer-1.2.12-parallel-build-slibtool.patch b/media-libs/sdl-mixer/files/sdl-mixer-1.2.12-parallel-build-slibtool.patch
deleted file mode 100644
index a9996f9b10e7..000000000000
--- a/media-libs/sdl-mixer/files/sdl-mixer-1.2.12-parallel-build-slibtool.patch
+++ /dev/null
@@ -1,92 +0,0 @@
-https://github.com/libsdl-org/SDL_mixer/pull/311
-
-This is the SDL 1 variant of the SDL 2 patch also in Gentoo.
-See: 36d63464d341868f0ba533188238c805710f16e0 (Gentoo)
-Bug: https://bugs.gentoo.org/777420
-
-From 0b3b8a5f886648c95ce5ed0abb3d4e9e181d7ca6 Mon Sep 17 00:00:00 2001
-From: orbea <orbea@riseup.net>
-Date: Tue, 6 Apr 2021 07:32:27 -0700
-Subject: [PATCH] build: Fix parallel make with slibtool.
-
----
-diff --git a/Makefile.in b/Makefile.in
-index 293608d..5d27df1 100644
---- a/Makefile.in
-+++ b/Makefile.in
-@@ -47,7 +47,7 @@ LT_RELEASE = @LT_RELEASE@
- LT_REVISION = @LT_REVISION@
- LT_LDFLAGS = -no-undefined -rpath $(libdir) -release $(LT_RELEASE) -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE)
-
--all: $(srcdir)/configure Makefile $(objects) $(objects)/$(TARGET) $(objects)/playwave$(EXE) $(objects)/playmus$(EXE)
-+all: $(srcdir)/configure Makefile $(objects)/$(TARGET) $(objects)/playwave$(EXE) $(objects)/playmus$(EXE)
-
- $(srcdir)/configure: $(srcdir)/configure.ac
- @echo "Warning, configure is out of date, please re-run autogen.sh"
-@@ -55,8 +55,9 @@ $(srcdir)/configure: $(srcdir)/configure.ac
- Makefile: $(srcdir)/Makefile.in
- $(SHELL) config.status $@
-
--$(objects):
-- $(SHELL) $(auxdir)/mkinstalldirs $@
-+$(objects)/.created:
-+ $(SHELL) $(auxdir)/mkinstalldirs $(objects)
-+ touch $@
-
- .PHONY: all install install-hdrs install-lib install-bin uninstall uninstall-hdrs uninstall-lib uninstall-bin clean distclean dist
-
-@@ -78,7 +79,7 @@ install-hdrs:
- done
- $(SHELL) $(auxdir)/mkinstalldirs $(libdir)/pkgconfig
- $(INSTALL) -m 644 SDL_mixer.pc $(libdir)/pkgconfig/
--install-lib: $(objects) $(objects)/$(TARGET)
-+install-lib: $(objects)/$(TARGET)
- $(SHELL) $(auxdir)/mkinstalldirs $(libdir)
- $(LIBTOOL) --mode=install $(INSTALL) $(objects)/$(TARGET) $(libdir)/$(TARGET)
- install-bin:
---- a/configure.in
-+++ b/configure.in
-@@ -626,14 +626,14 @@ OBJECTS=`echo $SOURCES`
- DEPENDS=`echo $SOURCES`
- OBJECTS=`echo "$OBJECTS" | sed 's,[[^ ]]*/\([[^ ]]*\)\.c,$(objects)/\1.lo,g'`
- DEPENDS=`echo "$DEPENDS" | sed 's,\([[^ ]]*\)/\([[^ ]]*\)\.c,\\
--$(objects)/\2.lo: \1/\2.c\\
-+$(objects)/\2.lo: \1/\2.c \$(objects)/.created\\
- \$(LIBTOOL) --mode=compile \$(CC) \$(CFLAGS) \$(EXTRA_CFLAGS) '"$DEPENDENCY_TRACKING_OPTIONS"' -c \$< -o \$@,g'`
-
- OBJECTS_CXX=`echo $SOURCES_CXX`
- DEPENDS_CXX=`echo $SOURCES_CXX`
- OBJECTS_CXX=`echo "$OBJECTS_CXX" | sed 's,[[^ ]]*/\([[^ ]]*\)\.cpp,$(objects)/\1.lo,g'`
- DEPENDS_CXX=`echo "$DEPENDS_CXX" | sed 's,\([[^ ]]*\)/\([[^ ]]*\)\.cpp,\\
--$(objects)/\2.lo: \1/\2.cpp\\
-+$(objects)/\2.lo: \1/\2.cpp \$(objects)/.created\\
- \$(LIBTOOL) --mode=compile \$(CXX) \$(CFLAGS) \$(EXTRA_CFLAGS) '"$DEPENDENCY_TRACKING_OPTIONS"' -c \$< -o \$@,g'`
- OBJECTS="$OBJECTS $OBJECTS_CXX"
- DEPENDS="$DEPENDS $DEPENDS_CXX"
-@@ -643,7 +643,7 @@ VERSION_OBJECTS=`echo $VERSION_SOURCES`
- VERSION_DEPENDS=`echo $VERSION_SOURCES`
- VERSION_OBJECTS=`echo "$VERSION_OBJECTS" | sed 's,[[^ ]]*/\([[^ ]]*\)\.rc,$(objects)/\1.o,g'`
- VERSION_DEPENDS=`echo "$VERSION_DEPENDS" | sed 's,\([[^ ]]*\)/\([[^ ]]*\)\.rc,\\
--$(objects)/\2.o: \1/\2.rc\\
-+$(objects)/\2.o: \1/\2.rc \$(objects)/.created\\
- \$(WINDRES) \$< \$@,g'`
- VERSION_DEPENDS=`echo "$VERSION_DEPENDS" | sed 's,\\$,\\\\$,g'`
-
-@@ -652,7 +652,7 @@ PLAYWAVE_OBJECTS=`echo $PLAYWAVE_SOURCES`
- PLAYWAVE_DEPENDS=`echo $PLAYWAVE_SOURCES`
- PLAYWAVE_OBJECTS=`echo "$PLAYWAVE_OBJECTS" | sed 's,[[^ ]]*/\([[^ ]]*\)\.c,$(objects)/\1.lo,g'`
- PLAYWAVE_DEPENDS=`echo "$PLAYWAVE_DEPENDS" | sed 's,\([[^ ]]*\)/\([[^ ]]*\)\.c,\\
--$(objects)/\2.lo: \1/\2.c\\
-+$(objects)/\2.lo: \1/\2.c \$(objects)/.created\\
- \$(LIBTOOL) --mode=compile \$(CC) \$(CFLAGS) \$(EXTRA_CFLAGS) '"$DEPENDENCY_TRACKING_OPTIONS"' -c \$< -o \$@,g'`
- PLAYWAVE_DEPENDS=`echo "$PLAYWAVE_DEPENDS" | sed 's,\\$,\\\\$,g'`
-
-@@ -661,7 +661,7 @@ PLAYMUS_OBJECTS=`echo $PLAYMUS_SOURCES`
- PLAYMUS_DEPENDS=`echo $PLAYMUS_SOURCES`
- PLAYMUS_OBJECTS=`echo "$PLAYMUS_OBJECTS" | sed 's,[[^ ]]*/\([[^ ]]*\)\.c,$(objects)/\1.lo,g'`
- PLAYMUS_DEPENDS=`echo "$PLAYMUS_DEPENDS" | sed 's,\([[^ ]]*\)/\([[^ ]]*\)\.c,\\
--$(objects)/\2.lo: \1/\2.c\\
-+$(objects)/\2.lo: \1/\2.c \$(objects)/.created\\
- \$(LIBTOOL) --mode=compile \$(CC) \$(CFLAGS) \$(EXTRA_CFLAGS) '"$DEPENDENCY_TRACKING_OPTIONS"' -c \$< -o \$@,g'`
- PLAYMUS_DEPENDS=`echo "$PLAYMUS_DEPENDS" | sed 's,\\$,\\\\$,g'`
-
diff --git a/media-libs/sdl-mixer/files/sdl-mixer-1.2.12-wav.patch b/media-libs/sdl-mixer/files/sdl-mixer-1.2.12-wav.patch
deleted file mode 100644
index 38914fd77f15..000000000000
--- a/media-libs/sdl-mixer/files/sdl-mixer-1.2.12-wav.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-https://bugs.gentoo.org/show_bug.cgi?id=406739
-Nikos Chantziaras 2012-03-03 03:13:39 EST
-
-There's a bug in the current version of SDL_mixer where failing to load a WAV sample will result in freeing a resource twice, resulting in an application crash. There is an upstream fix for this:
-
-http://hg.libsdl.org/SDL_mixer/rev/ea53a85853dd
-
-Upstream bug: http://bugzilla.libsdl.org/show_bug.cgi?id=1418
-
---- a/mixer.c
-+++ b/mixer.c
-@@ -610,13 +610,15 @@
- break;
- default:
- SDL_SetError("Unrecognized sound file type");
-- return(0);
-+ if ( freesrc ) {
-+ SDL_RWclose(src);
-+ }
-+ loaded = NULL;
-+ break;
- }
- if ( !loaded ) {
-+ /* The individual loaders have closed src if needed */
- SDL_free(chunk);
-- if ( freesrc ) {
-- SDL_RWclose(src);
-- }
- return(NULL);
- }
-
-
-
-
-