summaryrefslogtreecommitdiff
path: root/media-libs/rtaudio/files
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/rtaudio/files')
-rw-r--r--media-libs/rtaudio/files/rtaudio-4.0.11-cflags.patch24
-rw-r--r--media-libs/rtaudio/files/rtaudio-4.0.12-configure.patch73
-rw-r--r--media-libs/rtaudio/files/rtaudio-4.0.12-makefile.patch16
-rw-r--r--media-libs/rtaudio/files/rtaudio-4.1.2-cflags.patch12
-rw-r--r--media-libs/rtaudio/files/rtaudio-4.1.2-configure.patch68
5 files changed, 193 insertions, 0 deletions
diff --git a/media-libs/rtaudio/files/rtaudio-4.0.11-cflags.patch b/media-libs/rtaudio/files/rtaudio-4.0.11-cflags.patch
new file mode 100644
index 000000000000..9fa657929c21
--- /dev/null
+++ b/media-libs/rtaudio/files/rtaudio-4.0.11-cflags.patch
@@ -0,0 +1,24 @@
+--- rtaudio-4.0.11/configure.ac
++++ rtaudio-4.0.11/configure.ac
+@@ -23,8 +23,8 @@
+ AC_MSG_CHECKING(whether to compile debug version)
+ AC_ARG_ENABLE(debug,
+ [ --enable-debug = enable various debug output],
+- [AC_SUBST( cppflag, [-D__RTAUDIO_DEBUG__] ) AC_SUBST( cxxflag, [-g] ) AC_SUBST( object_path, [Debug] ) AC_MSG_RESULT(yes)],
+- [AC_SUBST( cppflag, [] ) AC_SUBST( cxxflag, [-O2] ) AC_SUBST( object_path, [Release] ) AC_MSG_RESULT(no)])
++ [AC_SUBST( cppflag, [-D__RTAUDIO_DEBUG__] ) AC_SUBST( object_path, [Debug] ) AC_MSG_RESULT(yes)],
++ [AC_SUBST( cppflag, [] ) AC_SUBST( object_path, [Release] ) AC_MSG_RESULT(no)])
+
+
+ # Checks for functions
+@@ -33,10 +33,6 @@
+ # For -I and -D flags
+ CPPFLAGS="$CPPFLAGS $cppflag"
+
+-# For debugging and optimization ... overwrite default because it has both -g and -O2
+-#CXXFLAGS="$CXXFLAGS $cxxflag"
+-CXXFLAGS="$cxxflag"
+-
+ # Check compiler and use -Wall if gnu.
+ if [test $GXX = "yes" ;] then
+ AC_SUBST( cxxflag, [-Wall] )
diff --git a/media-libs/rtaudio/files/rtaudio-4.0.12-configure.patch b/media-libs/rtaudio/files/rtaudio-4.0.12-configure.patch
new file mode 100644
index 000000000000..7680f75d40d3
--- /dev/null
+++ b/media-libs/rtaudio/files/rtaudio-4.0.12-configure.patch
@@ -0,0 +1,73 @@
+--- rtaudio-4.0.12/configure.ac
++++ rtaudio-4.0.12/configure.ac
+@@ -25,9 +25,9 @@
+ AC_PROG_CXX(g++ CC c++ cxx)
+ AC_PROG_RANLIB
+ AC_PATH_PROG(AR, ar, no)
+-if [[ $AR = "no" ]] ; then
+- AC_MSG_ERROR("Could not find ar - needed to create a library");
+-fi
++AS_IF([test "x$AR" == "x" ], [
++ AC_MSG_ERROR("Could not find ar - needed to create a library")
++])
+
+ # Checks for header files.
+ AC_HEADER_STDC
+@@ -83,39 +83,46 @@
+ ;;
+
+ *-*-linux*)
+- AC_ARG_WITH(jack, [ --with-jack = choose JACK server support (mac and linux only)], [
++ AC_ARG_WITH([jack], AS_HELP_STRING([--with-jack], [choose JACK server support (mac and linux only)]))
++
++ AS_IF([test "x$with_jack" != "xno"], [
+ api="$api -D__UNIX_JACK__"
+ AC_MSG_RESULT(using JACK)
+ AC_CHECK_LIB(jack, jack_client_open, , AC_MSG_ERROR(JACK support requires the jack library!))
+- AC_CHECK_LIB(asound, snd_pcm_open, , AC_MSG_ERROR(Jack support also requires the asound library!))], )
++ AC_CHECK_LIB(asound, snd_pcm_open, , AC_MSG_ERROR(Jack support also requires the asound library!))])
+
+ # Look for ALSA flag
+- AC_ARG_WITH(alsa, [ --with-alsa = choose native ALSA API support (linux only)], [
++ AC_ARG_WITH([alsa], AS_HELP_STRING([--with-alsa], [choose native ALSA API support (linux only)]))
++
++ AS_IF([test "x$with_alsa" != "xno"], [
+ api="$api -D__LINUX_ALSA__"
+ req="$req alsa"
+ AC_MSG_RESULT(using ALSA)
+- AC_CHECK_LIB(asound, snd_pcm_open, , AC_MSG_ERROR(ALSA support requires the asound library!))], )
++ AC_CHECK_LIB(asound, snd_pcm_open, , AC_MSG_ERROR(ALSA support requires the asound library!))])
+
+ # Look for PULSE flag
+- AC_ARG_WITH(pulse, [ --with-pulse = choose PulseAudio API support (linux only)], [
++ AC_ARG_WITH([pulse], AS_HELP_STRING([--with-pulse], [choose PulseAudio API support (linux only)]))
++
++ AS_IF([test "x$with_pulse" != "xno"], [
+ api="$api -D__LINUX_PULSE__"
+ req="$req libpulse-simple"
+ AC_MSG_RESULT(using PulseAudio)
+ PKG_CHECK_MODULES([PULSE], [libpulse-simple], , AC_MSG_ERROR(PulseAudio support requires the pulse-simple library!))
+- LIBS="$LIBS `pkg-config --libs libpulse-simple`" ], )
++ LIBS="$LIBS `pkg-config --libs libpulse-simple`" ])
+
+ # Look for OSS flag
+- AC_ARG_WITH(oss, [ --with-oss = choose OSS API support (linux only)], [
++ AC_ARG_WITH([oss], AS_HELP_STRING([--with-oss], [choose OSS API support (linux only)]))
++
++ AS_IF([test "x$with_oss" != "xno"], [
+ api="$api -D__LINUX_OSS__"
+- AC_MSG_RESULT(using OSS)], )
++ AC_MSG_RESULT(using OSS)])
+
+ # If no audio api flags specified, use ALSA
+- if [test "$api" == "";] then
++ AS_IF([test "x$api" == "x"], [
+ AC_MSG_RESULT(using ALSA)
+ AC_SUBST( api, [-D__LINUX_ALSA__] )
+ req="$req alsa"
+- AC_CHECK_LIB(asound, snd_pcm_open, , AC_MSG_ERROR(ALSA support requires the asound library!))
+- fi
++ AC_CHECK_LIB(asound, snd_pcm_open, , AC_MSG_ERROR(ALSA support requires the asound library!))])
+
+ AC_CHECK_LIB(pthread, pthread_create, , AC_MSG_ERROR(RtAudio requires the pthread library!))
+ ;;
diff --git a/media-libs/rtaudio/files/rtaudio-4.0.12-makefile.patch b/media-libs/rtaudio/files/rtaudio-4.0.12-makefile.patch
new file mode 100644
index 000000000000..adf109de5de9
--- /dev/null
+++ b/media-libs/rtaudio/files/rtaudio-4.0.12-makefile.patch
@@ -0,0 +1,16 @@
+--- rtaudio-4.0.12/Makefile.in
++++ rtaudio-4.0.12/Makefile.in
+@@ -24,9 +24,11 @@
+ tests:
+ cd tests && $(MAKE) all
+
+-$(LIBRARIES): $(OBJECTS)
++$(STATIC): $(OBJECTS)
+ $(AR) ruv $(STATIC) $(OBJECTS)
+- ranlib $(STATIC)
++ $(RANLIB) $(STATIC)
++
++$(SHARED): $(OBJECTS)
+ $(CC) -fPIC @libflags@ $(OBJECTS) @LIBS@
+ $(LN) -sf @sharedname@ $(SHARED)
+ $(LN) -sf @sharedname@ $(SHARED).$(MAJOR)
diff --git a/media-libs/rtaudio/files/rtaudio-4.1.2-cflags.patch b/media-libs/rtaudio/files/rtaudio-4.1.2-cflags.patch
new file mode 100644
index 000000000000..49978458c682
--- /dev/null
+++ b/media-libs/rtaudio/files/rtaudio-4.1.2-cflags.patch
@@ -0,0 +1,12 @@
+--- rtaudio-4.1.2/configure.ac
++++ rtaudio-4.1.2/configure.ac
+@@ -62,8 +62,7 @@
+ AC_MSG_CHECKING(whether to compile debug version)
+ AC_ARG_ENABLE(debug,
+ [AS_HELP_STRING([--enable-debug],[enable various debug output])],
+- [: ${CXXFLAGS="-g -O0"};] [AC_DEFINE([__RTAUDIO_DEBUG__])],
+- [: ${CXXFLAGS="-O3"}])
++ [AC_DEFINE([__RTAUDIO_DEBUG__])], )
+
+ # Checks for programs.
+ AC_PROG_CXX(g++ CC c++ cxx)
diff --git a/media-libs/rtaudio/files/rtaudio-4.1.2-configure.patch b/media-libs/rtaudio/files/rtaudio-4.1.2-configure.patch
new file mode 100644
index 000000000000..fa33fb21fee2
--- /dev/null
+++ b/media-libs/rtaudio/files/rtaudio-4.1.2-configure.patch
@@ -0,0 +1,68 @@
+--- rtaudio-4.1.2/configure.ac
++++ rtaudio-4.1.2/configure.ac
+@@ -69,9 +69,9 @@
+ AC_PROG_CXX(g++ CC c++ cxx)
+ AM_PROG_AR
+ AC_PATH_PROG(AR, ar, no)
+-if [[ $AR = "no" ]] ; then
+- AC_MSG_ERROR("Could not find ar - needed to create a library");
+-fi
++AS_IF([test "x$AR" == "x" ], [
++ AC_MSG_ERROR("Could not find ar - needed to create a library")
++])
+
+ # Initialize libtool
+ LT_INIT([win32-dll])
+@@ -131,38 +130,41 @@
+ ;;
+
+ *-*-linux*)
+- AC_ARG_WITH(jack, [ --with-jack = choose JACK server support (mac and linux only)], [
++ AC_ARG_WITH([jack], AS_HELP_STRING([--with-jack], [choose JACK server support (mac and linux only)]))
++ AS_IF([test "x$with_jack" != "xno"], [
+ api="$api -D__UNIX_JACK__"
+ AC_MSG_RESULT(using JACK)
+ AC_CHECK_LIB(jack, jack_client_open, , AC_MSG_ERROR(JACK support requires the jack library!))
+- AC_CHECK_LIB(asound, snd_pcm_open, , AC_MSG_ERROR(Jack support also requires the asound library!))], )
++ AC_CHECK_LIB(asound, snd_pcm_open, , AC_MSG_ERROR(Jack support also requires the asound library!))])
+
+ # Look for ALSA flag
+- AC_ARG_WITH(alsa, [ --with-alsa = choose native ALSA API support (linux only)], [
++ AC_ARG_WITH([alsa], AS_HELP_STRING([--with-alsa], [choose native ALSA API support (linux only)]))
++ AS_IF([test "x$with_alsa" != "xno"], [
+ api="$api -D__LINUX_ALSA__"
+ req="$req alsa"
+ AC_MSG_RESULT(using ALSA)
+- AC_CHECK_LIB(asound, snd_pcm_open, , AC_MSG_ERROR(ALSA support requires the asound library!))], )
++ AC_CHECK_LIB(asound, snd_pcm_open, , AC_MSG_ERROR(ALSA support requires the asound library!))])
+
+ # Look for PULSE flag
+- AC_ARG_WITH(pulse, [ --with-pulse = choose PulseAudio API support (linux only)], [
++ AC_ARG_WITH([pulse], AS_HELP_STRING([--with-pulse], [choose PulseAudio API support (linux only)]))
++ AS_IF([test "x$with_pulse" != "xno"], [
+ api="$api -D__LINUX_PULSE__"
+ req="$req libpulse-simple"
+ AC_MSG_RESULT(using PulseAudio)
+- AC_CHECK_LIB(pulse-simple, pa_simple_flush, , AC_MSG_ERROR(PulseAudio support requires the pulse-simple library!))], )
++ AC_CHECK_LIB(pulse-simple, pa_simple_flush, , AC_MSG_ERROR(PulseAudio support requires the pulse-simple library!))])
+
+ # Look for OSS flag
+- AC_ARG_WITH(oss, [ --with-oss = choose OSS API support (linux only)], [
++ AC_ARG_WITH([oss], AS_HELP_STRING([--with-oss], [choose OSS API support (linux only)]))
++ AS_IF([test "x$with_oss" != "xno"], [
+ api="$api -D__LINUX_OSS__"
+- AC_MSG_RESULT(using OSS)], )
++ AC_MSG_RESULT(using OSS)])
+
+ # If no audio api flags specified, use ALSA
+- if [test "$api" == "";] then
++ AS_IF([test "x$api" == "x"], [
+ AC_MSG_RESULT(using ALSA)
+ AC_SUBST( api, [-D__LINUX_ALSA__] )
+ req="$req alsa"
+- AC_CHECK_LIB(asound, snd_pcm_open, , AC_MSG_ERROR(ALSA support requires the asound library!))
+- fi
++ AC_CHECK_LIB(asound, snd_pcm_open, , AC_MSG_ERROR(ALSA support requires the asound library!))])
+
+ AC_CHECK_LIB(pthread, pthread_create, , AC_MSG_ERROR(RtAudio requires the pthread library!))
+ ;;