summaryrefslogtreecommitdiff
path: root/media-libs/quarter/quarter-1.0.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/quarter/quarter-1.0.0-r1.ebuild')
-rw-r--r--media-libs/quarter/quarter-1.0.0-r1.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/media-libs/quarter/quarter-1.0.0-r1.ebuild b/media-libs/quarter/quarter-1.0.0-r1.ebuild
deleted file mode 100644
index 48b626a3fbb1..000000000000
--- a/media-libs/quarter/quarter-1.0.0-r1.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit autotools-utils flag-o-matic
-
-MY_P="${P/q/Q}"
-
-DESCRIPTION="A glue between Nokia Qt4 and Coin3D"
-HOMEPAGE="http://www.coin3d.org/lib/quarter"
-SRC_URI="ftp://ftp.coin3d.org/pub/coin/src/all/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
-IUSE="debug doc static-libs"
-
-RDEPEND="
- >=media-libs/coin-3.0.0[javascript]
- dev-qt/designer:4
- dev-qt/qtcore:4
- dev-qt/qtgui:4
- dev-qt/qtopengl:4
- virtual/opengl
-"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- doc? ( app-doc/doxygen )
-"
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=(
- "${FILESDIR}/${P}-gcc44.patch"
-)
-
-DOCS=(AUTHORS NEWS README)
-
-src_configure() {
- append-libs -lGL #369967, library calls glEnable()
-
- local myeconfargs=(
- htmldir="${ROOT}usr/share/doc/${PF}/html"
- --enable-pkgconfig
- --with-coin
- $(use_enable debug)
- $(use_enable debug symbols)
- $(use_enable doc html)
- )
- autotools-utils_src_configure
-}