summaryrefslogtreecommitdiff
path: root/media-libs/phonon-qt7/files
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/phonon-qt7/files')
-rw-r--r--media-libs/phonon-qt7/files/phonon-qt7-0_pre20110424-QWidget-cast-dynamic.patch28
-rw-r--r--media-libs/phonon-qt7/files/phonon-qt7-0_pre20110424-darwin11.patch29
-rw-r--r--media-libs/phonon-qt7/files/phonon-qt7-noshow.patch17
3 files changed, 0 insertions, 74 deletions
diff --git a/media-libs/phonon-qt7/files/phonon-qt7-0_pre20110424-QWidget-cast-dynamic.patch b/media-libs/phonon-qt7/files/phonon-qt7-0_pre20110424-QWidget-cast-dynamic.patch
deleted file mode 100644
index ae222027b892..000000000000
--- a/media-libs/phonon-qt7/files/phonon-qt7-0_pre20110424-QWidget-cast-dynamic.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-Revert commit:
-
-commit b22b86f6940d2605e78398eca4ae05c3ea44a92c
-Author: Ritt Konstantin <ritt.ks@gmail.com>
-Date: Thu Jun 10 07:38:14 2010 +0400
-
- fix build with -fno-rtti
-
- m_renderDrawWidget object inherits QWidget and can be safely static_cast-ed
-
-as it yields in:
-
-error: invalid static_cast from type ‘Phonon::QT7::IVideoRenderDrawWidget*’ to type ‘QWidget*’
-
-
-diff --git a/qt7/videowidget.mm b/qt7/videowidget.mm
-index 736dcdf..e471140 100644
---- a/qt7/videowidget.mm
-+++ b/qt7/videowidget.mm
-@@ -578,7 +578,7 @@ public:
- PhononAutoReleasePool pool;
- updateDrawFrameRect();
- if (m_renderDrawWidget)
-- static_cast<QWidget *>(m_renderDrawWidget)->resize(size());
-+ dynamic_cast<QWidget *>(m_renderDrawWidget)->resize(size());
- break; }
- case QEvent::Paint:{
- PhononAutoReleasePool pool;
diff --git a/media-libs/phonon-qt7/files/phonon-qt7-0_pre20110424-darwin11.patch b/media-libs/phonon-qt7/files/phonon-qt7-0_pre20110424-darwin11.patch
deleted file mode 100644
index 6d1a5626a207..000000000000
--- a/media-libs/phonon-qt7/files/phonon-qt7-0_pre20110424-darwin11.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-disable AUGraphAddNode, it needs an AudioComponent iso Component
-need a definition for gnuOrtho2D
-
---- phonon-qt7/qt7/audionode.mm
-+++ phonon-qt7/qt7/audionode.mm
-@@ -69,9 +69,9 @@
-
- OSStatus err = noErr;
- #if MAC_OS_X_VERSION_MAX_ALLOWED >= MAC_OS_X_VERSION_10_5
-- if (QSysInfo::MacintoshVersion >= QSysInfo::MV_10_5)
-- err = AUGraphAddNode(m_audioGraph->audioGraphRef(), &description, &m_auNode);
-- else
-+// if (QSysInfo::MacintoshVersion >= QSysInfo::MV_10_5)
-+// err = AUGraphAddNode(m_audioGraph->audioGraphRef(), &description, &m_auNode);
-+// else
- #endif
- err = AUGraphNewNode(m_audioGraph->audioGraphRef(), &description, 0, 0, &m_auNode);
-
---- phonon-qt7/qt7/videowidget.mm
-+++ phonon-qt7/qt7/videowidget.mm
-@@ -35,6 +35,8 @@
- #import <AppKit/NSImage.h>
- #import <QTKit/QTMovieView.h>
-
-+#import <OpenGL/glu.h>
-+
- /////////////////////////////////////////////////////////////////////////////////////////
-
- #ifdef QT_MAC_USE_COCOA // Rendering to a QTMovieView can only be done in Cocoa
diff --git a/media-libs/phonon-qt7/files/phonon-qt7-noshow.patch b/media-libs/phonon-qt7/files/phonon-qt7-noshow.patch
deleted file mode 100644
index e05c2c4d9957..000000000000
--- a/media-libs/phonon-qt7/files/phonon-qt7-noshow.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-diff -ruN phonon-qt7.orig/CMakeLists.txt phonon-qt7/CMakeLists.txt
---- phonon-qt7.orig/CMakeLists.txt 2011-04-24 20:22:59.000000000 +0200
-+++ phonon-qt7/CMakeLists.txt 2011-04-24 20:42:15.000000000 +0200
-@@ -2,6 +2,8 @@
-
- cmake_minimum_required(VERSION 2.6.2 FATAL_ERROR)
-
-+set(CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmake")
-+
- find_package(Phonon REQUIRED)
- find_package(OpenGL REQUIRED)
-
-@@ -17,4 +19,3 @@
- add_subdirectory(qt7)
- endif (Q_WS_MAC)
-
--macro_display_feature_log()