summaryrefslogtreecommitdiff
path: root/media-libs/phonon-gstreamer/phonon-gstreamer-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/phonon-gstreamer/phonon-gstreamer-9999.ebuild')
-rw-r--r--media-libs/phonon-gstreamer/phonon-gstreamer-9999.ebuild40
1 files changed, 11 insertions, 29 deletions
diff --git a/media-libs/phonon-gstreamer/phonon-gstreamer-9999.ebuild b/media-libs/phonon-gstreamer/phonon-gstreamer-9999.ebuild
index 24ced106443d..777afe2e954d 100644
--- a/media-libs/phonon-gstreamer/phonon-gstreamer-9999.ebuild
+++ b/media-libs/phonon-gstreamer/phonon-gstreamer-9999.ebuild
@@ -3,55 +3,37 @@
EAPI=7
-MY_PN="phonon-backend-gstreamer"
-MY_P=${MY_PN}-${PV}
+inherit kde5
-if [[ ${PV} != *9999* ]]; then
- SRC_URI="mirror://kde/stable/phonon/${MY_PN}/${PV}/${MY_P}.tar.xz"
+DESCRIPTION="GStreamer backend for the Phonon multimedia library"
+HOMEPAGE="https://phonon.kde.org/"
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ SRC_URI="mirror://kde/stable/phonon/phonon-backend-gstreamer/${PV}/phonon-backend-gstreamer-${PV}.tar.xz"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-fbsd"
-else
- EGIT_REPO_URI=( "git://anongit.kde.org/${PN}" )
- inherit git-r3
fi
-inherit cmake-utils xdg-utils
-
-DESCRIPTION="Phonon GStreamer backend"
-HOMEPAGE="https://phonon.kde.org/"
-
LICENSE="LGPL-2.1+ || ( LGPL-2.1 LGPL-3 )"
SLOT="0"
IUSE="alsa debug +network"
BDEPEND="
+ dev-qt/linguist-tools:5
virtual/pkgconfig
"
DEPEND="
dev-libs/glib:2
dev-libs/libxml2:2
- dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtopengl:5
dev-qt/qtwidgets:5
dev-qt/qtx11extras:5
- media-libs/gstreamer:1.0
media-libs/gst-plugins-base:1.0
- >=media-libs/phonon-4.10.0
+ media-libs/gstreamer:1.0
+ >=media-libs/phonon-4.10.60
media-plugins/gst-plugins-meta:1.0[alsa?,ogg,vorbis]
virtual/opengl
+"
+RDEPEND="${DEPEND}
network? ( media-plugins/gst-plugins-soup:1.0 )
"
-RDEPEND="${DEPEND}"
-
-src_configure() {
- local mycmakeargs=( -DPHONON_BUILD_PHONON4QT5=ON )
- cmake-utils_src_configure
-}
-
-pkg_postinst() {
- xdg_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
-}