summaryrefslogtreecommitdiff
path: root/media-libs/osl/osl-1.12.14.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/osl/osl-1.12.14.0.ebuild')
-rw-r--r--media-libs/osl/osl-1.12.14.0.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/media-libs/osl/osl-1.12.14.0.ebuild b/media-libs/osl/osl-1.12.14.0.ebuild
index 5af6590d6486..459fa3084277 100644
--- a/media-libs/osl/osl-1.12.14.0.ebuild
+++ b/media-libs/osl/osl-1.12.14.0.ebuild
@@ -26,7 +26,7 @@ X86_CPU_FEATURES=(
)
CPU_FEATURES=( ${X86_CPU_FEATURES[@]/#/cpu_flags_x86_} )
-IUSE="doc gui partio qt6 test ${CPU_FEATURES[@]%:*} python"
+IUSE="debug doc gui partio qt6 test ${CPU_FEATURES[@]%:*} python"
RESTRICT="!test? ( test )"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
@@ -124,9 +124,14 @@ src_configure() {
-DPYTHON_VERSION="${EPYTHON/python}"
-DUSE_SIMD="$(IFS=","; echo "${mysimd[*]}")"
-DUSE_BATCHED="$(IFS=","; echo "${mybatched[*]}")"
- -DVEC_REPORT=yes
)
+ if use debug; then
+ mycmakeargs+=(
+ -DVEC_REPORT="yes"
+ )
+ fi
+
if use gui; then
mycmakeargs+=( -DUSE_QT=yes )
if ! use qt6; then