summaryrefslogtreecommitdiff
path: root/media-libs/opensubdiv/files
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/opensubdiv/files')
-rw-r--r--media-libs/opensubdiv/files/opensubdiv-3.1.0-skip-osd-regression.patch34
-rw-r--r--media-libs/opensubdiv/files/opensubdiv-3.3.0-add-CUDA9-compatibility.patch25
2 files changed, 25 insertions, 34 deletions
diff --git a/media-libs/opensubdiv/files/opensubdiv-3.1.0-skip-osd-regression.patch b/media-libs/opensubdiv/files/opensubdiv-3.1.0-skip-osd-regression.patch
deleted file mode 100644
index 2ebb638e3838..000000000000
--- a/media-libs/opensubdiv/files/opensubdiv-3.1.0-skip-osd-regression.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-diff -purN a/regression/CMakeLists.txt b/regression/CMakeLists.txt
---- a/regression/CMakeLists.txt 2016-03-25 22:15:29.000000000 +0000
-+++ b/regression/CMakeLists.txt 2016-06-05 14:09:19.202849569 +0100
-@@ -32,30 +32,4 @@ if (NOT NO_REGRESSION)
-
- add_subdirectory(far_perf)
-
-- if(OPENGL_FOUND AND (GLEW_FOUND OR APPLE) AND GLFW_FOUND)
-- add_subdirectory(osd_regression)
-- else()
-- set(MISSING "")
--
-- if (NOT OPENGL_FOUND)
-- list(APPEND MISSING OpenGL)
-- endif()
--
-- if (NOT GLEW_FOUND)
-- list(APPEND MISSING glew)
-- endif()
--
-- if (NOT GLFW_FOUND)
-- list(APPEND MISSING glfw)
-- endif()
--
-- message(WARNING
-- "The following libraries could not be found : ${MISSING}. "
-- "The osd regression test will not be available. "
-- "If you have these libraries installed, please specify their "
-- "path to cmake (through the GLEW_LOCATION and GLFW_LOCATION "
-- "command line arguments or environment variables)."
-- )
-- endif()
--
- endif()
diff --git a/media-libs/opensubdiv/files/opensubdiv-3.3.0-add-CUDA9-compatibility.patch b/media-libs/opensubdiv/files/opensubdiv-3.3.0-add-CUDA9-compatibility.patch
new file mode 100644
index 000000000000..9fe81c4ee199
--- /dev/null
+++ b/media-libs/opensubdiv/files/opensubdiv-3.3.0-add-CUDA9-compatibility.patch
@@ -0,0 +1,25 @@
+From 7b9157bca7138480c387ef3d5b69b6cf1eb498e5 Mon Sep 17 00:00:00 2001
+From: "Daniel M. Weeks" <dan@danweeks.net>
+Date: Fri, 15 Dec 2017 22:45:55 -0500
+Subject: [PATCH] CUDA 9 compatible gpu-architecture default
+
+---
+ CMakeLists.txt | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 4f3cd9d4..fa438b46 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -513,8 +513,10 @@ if(CUDA_FOUND)
+ if (NOT DEFINED OSD_CUDA_NVCC_FLAGS)
+ if (CUDA_VERSION_MAJOR LESS 6)
+ set( OSD_CUDA_NVCC_FLAGS --gpu-architecture compute_11 )
+- else()
++ elseif (CUDA_VERSION_MAJOR LESS 9)
+ set( OSD_CUDA_NVCC_FLAGS --gpu-architecture compute_20 )
++ else()
++ set( OSD_CUDA_NVCC_FLAGS --gpu-architecture compute_30 )
+ endif()
+ endif()
+ endif()