summaryrefslogtreecommitdiff
path: root/media-libs/openexr/openexr-1.7.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/openexr/openexr-1.7.0.ebuild')
-rw-r--r--media-libs/openexr/openexr-1.7.0.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/media-libs/openexr/openexr-1.7.0.ebuild b/media-libs/openexr/openexr-1.7.0.ebuild
deleted file mode 100644
index ac9a2a1e958b..000000000000
--- a/media-libs/openexr/openexr-1.7.0.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=2
-inherit eutils libtool
-
-DESCRIPTION="ILM's OpenEXR high dynamic-range image file format libraries"
-HOMEPAGE="http://openexr.com/"
-SRC_URI="http://download.savannah.gnu.org/releases/openexr/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 -arm hppa ia64 ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd"
-IUSE="examples static-libs"
-
-RDEPEND="sys-libs/zlib
- >=media-libs/ilmbase-1.0.2"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-src_prepare() {
- sed -i \
- -e "s:/var/tmp/:${T}:" \
- IlmImfTest/tmpDir.h || die # Fix path for testsuite
-
- epatch "${FILESDIR}"/${P}-gcc43.patch
-
- elibtoolize
-}
-
-src_configure() {
- econf \
- --disable-dependency-tracking \
- $(use_enable static-libs static) \
- $(use_enable examples imfexamples)
-}
-
-src_install() {
- emake \
- DESTDIR="${D}" \
- docdir="/usr/share/doc/${PF}/pdf" \
- examplesdir="/usr/share/doc/${PF}/examples" \
- install || die
-
- dodoc AUTHORS ChangeLog NEWS README
-
- if use examples; then
- dobin IlmImfExamples/imfexamples || die
- else
- rm -rf "${D}"/usr/share/doc/${PF}/examples
- fi
-
- find "${D}" -name '*.la' -delete
-}