summaryrefslogtreecommitdiff
path: root/media-libs/openexr/files/openexr-2.3.0-tests-32bits.patch
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/openexr/files/openexr-2.3.0-tests-32bits.patch')
-rw-r--r--media-libs/openexr/files/openexr-2.3.0-tests-32bits.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/media-libs/openexr/files/openexr-2.3.0-tests-32bits.patch b/media-libs/openexr/files/openexr-2.3.0-tests-32bits.patch
new file mode 100644
index 000000000000..430bb20bcfae
--- /dev/null
+++ b/media-libs/openexr/files/openexr-2.3.0-tests-32bits.patch
@@ -0,0 +1,36 @@
+Description: Fix test-suite on some 32bits archs
+Author: Mathieu Malaterre <malat@debian.org>
+Bug-Debian: https://bugs.debian.org/791478
+
+Index: openexr/IlmImfTest/Makefile.am
+===================================================================
+--- openexr.orig/IlmImfTest/Makefile.am
++++ openexr/IlmImfTest/Makefile.am
+@@ -44,7 +44,6 @@ IlmImfTest_SOURCES = main.cpp tmpDir.h t
+ testDeepScanLineMultipleRead.h testDeepScanLineMultipleRead.cpp \
+ testPartHelper.h testPartHelper.cpp \
+ testOptimized.cpp testOptimized.h \
+- testOptimizedInterleavePatterns.cpp testOptimizedInterleavePatterns.h \
+ testBadTypeAttributes.cpp testBadTypeAttributes.h \
+ testFutureProofing.cpp testFutureProofing.h \
+ compareDwa.cpp compareDwa.h \
+Index: openexr/IlmImfTest/main.cpp
+===================================================================
+--- openexr.orig/IlmImfTest/main.cpp
++++ openexr/IlmImfTest/main.cpp
+@@ -82,7 +82,6 @@
+ #include "testCopyMultiPartFile.h"
+ #include "testPartHelper.h"
+ #include "testOptimized.h"
+-#include "testOptimizedInterleavePatterns.h"
+ #include "testBadTypeAttributes.h"
+ #include "testFutureProofing.h"
+ #include "testPartHelper.h"
+@@ -174,7 +173,6 @@ main (int argc, char *argv[])
+ TEST (testExistingStreams, "core");
+ TEST (testStandardAttributes, "core");
+ TEST (testOptimized, "basic");
+- TEST (testOptimizedInterleavePatterns, "basic");
+ TEST (testYca, "basic");
+ TEST (testTiledYa, "basic");
+ TEST (testNativeFormat, "basic");