summaryrefslogtreecommitdiff
path: root/media-libs/mutagen/mutagen-1.35.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/mutagen/mutagen-1.35.1.ebuild')
-rw-r--r--media-libs/mutagen/mutagen-1.35.1.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/media-libs/mutagen/mutagen-1.35.1.ebuild b/media-libs/mutagen/mutagen-1.35.1.ebuild
deleted file mode 100644
index 6a033ff26f50..000000000000
--- a/media-libs/mutagen/mutagen-1.35.1.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_5} )
-
-inherit distutils-r1
-
-DESCRIPTION="Audio metadata tag reader and writer implemented in pure Python"
-HOMEPAGE="https://bitbucket.org/lazka/mutagen https://pypi.org/project/mutagen/"
-SRC_URI="https://bitbucket.org/lazka/${PN}/downloads/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-
-# TODO: Missing support for >=dev-python/eyeD3-0.7 API
-# test? ( >=dev-python/eyeD3-0.7 )
-RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )
-"
-
-python_compile_all() {
- use doc && emake -C docs
-}
-
-src_test() {
- # tests/test_flac.py uses temp files with a constant path.
- # If we had multiple python implementations, we would hit a race.
- distutils-r1_src_test
-}
-
-python_test() {
- esetup.py test
-}
-
-python_install_all() {
- local DOCS=( NEWS README.rst )
- use doc && local HTML_DOCS=( docs/_build/. )
- distutils-r1_python_install_all
-}