summaryrefslogtreecommitdiff
path: root/media-libs/mesa/mesa-23.1.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/mesa/mesa-23.1.3.ebuild')
-rw-r--r--media-libs/mesa/mesa-23.1.3.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/media-libs/mesa/mesa-23.1.3.ebuild b/media-libs/mesa/mesa-23.1.3.ebuild
index 9967d104c9cf..c44daa0c39c2 100644
--- a/media-libs/mesa/mesa-23.1.3.ebuild
+++ b/media-libs/mesa/mesa-23.1.3.ebuild
@@ -132,7 +132,7 @@ PER_SLOT_DEPSTR="
!opencl? ( sys-devel/llvm:@SLOT@[${LLVM_USE_DEPS}] )
opencl? ( sys-devel/clang:@SLOT@[${LLVM_USE_DEPS}] )
opencl? ( dev-util/spirv-llvm-translator:@SLOT@ )
- vulkan? ( video_cards_intel? ( dev-util/spirv-llvm-translator:@SLOT@ ) )
+ vulkan? ( video_cards_intel? ( amd64? ( dev-util/spirv-llvm-translator:@SLOT@ ) ) )
)
"
LLVM_DEPSTR="
@@ -194,7 +194,7 @@ llvm_check_deps() {
if use opencl; then
has_version "sys-devel/clang:${LLVM_SLOT}[${LLVM_USE_DEPS}]" || return 1
fi
- if use opencl || { use vulkan && use video_cards_intel; }; then
+ if use opencl || { use vulkan && use video_cards_intel && use amd64; }; then
has_version "dev-util/spirv-llvm-translator:${LLVM_SLOT}" || return 1
fi
has_version "sys-devel/llvm:${LLVM_SLOT}[${LLVM_USE_DEPS}]"