summaryrefslogtreecommitdiff
path: root/media-libs/libzen/libzen-0.4.39.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libzen/libzen-0.4.39.ebuild')
-rw-r--r--media-libs/libzen/libzen-0.4.39.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/media-libs/libzen/libzen-0.4.39.ebuild b/media-libs/libzen/libzen-0.4.39.ebuild
new file mode 100644
index 000000000000..f4c444cbce43
--- /dev/null
+++ b/media-libs/libzen/libzen-0.4.39.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+MY_PN="ZenLib"
+DESCRIPTION="Shared library for libmediainfo and mediainfo"
+HOMEPAGE="https://github.com/MediaArea/ZenLib"
+SRC_URI="https://mediaarea.net/download/source/${PN}/${PV}/${P/-/_}.tar.bz2"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc static-libs"
+
+BDEPEND="virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+S=${WORKDIR}/${MY_PN}/Project/GNU/Library
+
+src_prepare() {
+ default
+
+ sed -i 's:-O2::' configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-unicode \
+ --enable-shared \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ default
+
+ if use doc ; then
+ cd "${WORKDIR}"/${MY_PN}/Source/Doc
+ doxygen Doxyfile || die
+ fi
+}
+
+src_install() {
+ default
+
+ # remove since the pkgconfig file should be used instead
+ rm "${D}"/usr/bin/libzen-config
+
+ insinto /usr/$(get_libdir)/pkgconfig
+ doins ${PN}.pc
+
+ for x in ./ Format/Html Format/Http HTTP_Client ; do
+ insinto /usr/include/${MY_PN}/${x}
+ doins "${WORKDIR}"/${MY_PN}/Source/${MY_PN}/${x}/*.h
+ done
+
+ dodoc "${WORKDIR}"/${MY_PN}/History.txt
+ if use doc ; then
+ docinto html
+ dodoc "${WORKDIR}"/${MY_PN}/Doc/*
+ fi
+
+ find "${ED}" -name '*.la' -delete || die
+}