summaryrefslogtreecommitdiff
path: root/media-libs/libvisual/libvisual-0.4.0-r4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libvisual/libvisual-0.4.0-r4.ebuild')
-rw-r--r--media-libs/libvisual/libvisual-0.4.0-r4.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/media-libs/libvisual/libvisual-0.4.0-r4.ebuild b/media-libs/libvisual/libvisual-0.4.0-r4.ebuild
new file mode 100644
index 000000000000..374efaea922d
--- /dev/null
+++ b/media-libs/libvisual/libvisual-0.4.0-r4.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="Abstraction library between applications and audio visualisation plugins"
+HOMEPAGE="http://libvisual.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0.4"
+KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv sparc x86"
+IUSE="debug nls threads"
+
+BDEPEND="
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-better-altivec-detection.patch
+ "${FILESDIR}"/${P}-inlinedefineconflict.patch
+ "${FILESDIR}"/${P}-conditions.patch
+ "${FILESDIR}"/${P}-detect_amd64.patch
+ "${FILESDIR}"/${P}-cond.patch
+ "${FILESDIR}"/${P}-format-security.patch
+)
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/libvisual-0.4/libvisual/lvconfig.h
+)
+
+src_prepare() {
+ default
+
+ # autogenerated, causes problems for out of tree builds
+ rm libvisual/lvconfig.h || die
+
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ --disable-static \
+ $(use_enable nls) \
+ $(use_enable threads) \
+ $(use_enable debug)
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ # no static archives
+ find "${ED}" -name '*.la' -delete || die
+}