summaryrefslogtreecommitdiff
path: root/media-libs/libsidplayfp
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libsidplayfp')
-rw-r--r--media-libs/libsidplayfp/Manifest2
-rw-r--r--media-libs/libsidplayfp/libsidplayfp-2.1.2.ebuild32
2 files changed, 34 insertions, 0 deletions
diff --git a/media-libs/libsidplayfp/Manifest b/media-libs/libsidplayfp/Manifest
index 287cfcde67d5..dc7a974584ed 100644
--- a/media-libs/libsidplayfp/Manifest
+++ b/media-libs/libsidplayfp/Manifest
@@ -1,3 +1,5 @@
DIST libsidplayfp-1.8.8.tar.gz 673522 BLAKE2B 2d31955e08b0b2b9558e033eff5d959acda08cdc5a3c2bb8c0aacb07c4b8c105812b4faa0af07dbc51255c72cfdf4893ce0da4d642dfc0f89ebc6ec96c51db51 SHA512 84fb24dcf6680dd0e2ec9cc39ddaf30707e4beb5136b7b496b1b85bf11580b1080fbb59b6ec3c1dc7b829fa0cd933db89ee3968518f23ef1a35d9253707d6392
+DIST libsidplayfp-2.1.2.tar.gz 788212 BLAKE2B 1959404d8b694e9271276bd3a7d32298747fcfc52fc96da3ebae16e23ed9c1825cda4810bff5ad39a0ca7f173300f6b86791ff589ee78bf05c9e12bc49bccaf5 SHA512 c044cc835666a7616b2c16e8f186877caa42c80c74ae2fd503868f77311ed6bc8df58cbb72e7086477adec1ba314bd4f1410a733642ff18baf1596afa1a9b22b
EBUILD libsidplayfp-1.8.8.ebuild 837 BLAKE2B c895321c29600fd9d7a46c429606dbc1efd60c376e437a84cc5edb4c16abaf12cb02c3e3a38971be3a5684bca2ac6309c7b45d6805be36dbd71cc5a351411754 SHA512 d2452be2e98918d9fd8a694b80c5cfa60118fe9578b0b8a212b8e51deb04d22e503684865469b236a33b4db8eb0988dedf855ca0ec80d88ee5a20551ba614fe2
+EBUILD libsidplayfp-2.1.2.ebuild 747 BLAKE2B 02b40f4d38913c921db9e63cecc122a2eaf982389c35ae9e31fa2c03c7ad300ed1e0c766c9ad7d23105a72a6fc78d76402a1b2c479c03d7b0fe8ddf00ec21208 SHA512 6b92125a4ab7212433be9e8076cb036be45ca1434639b3b5dfcae331564f48b3c88c5d73079ce3169f93d7658c56a75275e58a3bd4ca4a9a80a292a56a34aeee
MISC metadata.xml 338 BLAKE2B 8f2f847b878e42e85fed57021162ccfd8cb8b54e6c285cea2691b9dd89ab320a59e4df38ae12414eaa81d7f781f81fd6d102e37f0121f98a2d9355ac8e9c131a SHA512 8f2ffc3fd7b2b6af0143e4125cad702a68da198e0433fd3d22775ca1f64d8689acf3cc0fdbd205d7fc0815b95c1c88fa1cca71c3f5572f3aa3b25bb8b3a9b76e
diff --git a/media-libs/libsidplayfp/libsidplayfp-2.1.2.ebuild b/media-libs/libsidplayfp/libsidplayfp-2.1.2.ebuild
new file mode 100644
index 000000000000..8712fad9752d
--- /dev/null
+++ b/media-libs/libsidplayfp/libsidplayfp-2.1.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic
+
+DESCRIPTION="Library for the sidplay2 fork with resid-fp"
+HOMEPAGE="https://sourceforge.net/projects/sidplay-residfp/"
+SRC_URI="mirror://sourceforge/sidplay-residfp/${PN}/$(ver_cut 1-2)/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/6"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="cpu_flags_x86_mmx static-libs"
+
+src_prepare() {
+ default
+ # fix automagic. warning: modifying .ac triggers maintainer mode.
+ sed -i -e 's:doxygen:dIsAbLe&:' configure || die
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable cpu_flags_x86_mmx mmx)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}