summaryrefslogtreecommitdiff
path: root/media-libs/libreplaygain/libreplaygain-483.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libreplaygain/libreplaygain-483.ebuild')
-rw-r--r--media-libs/libreplaygain/libreplaygain-483.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/media-libs/libreplaygain/libreplaygain-483.ebuild b/media-libs/libreplaygain/libreplaygain-483.ebuild
new file mode 100644
index 000000000000..577348b1e2b3
--- /dev/null
+++ b/media-libs/libreplaygain/libreplaygain-483.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+# svn export http://svn.musepack.net/libreplaygain@${PV} libreplaygain-${PV}
+# tar -cJf libreplaygain-${PV}.tar.xz libreplaygain-${PV}
+
+DESCRIPTION="Replay Gain library from Musepack"
+HOMEPAGE="https://www.musepack.net/"
+SRC_URI="https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+PATCHES=( "${FILESDIR}"/${P}-static-libs.patch )
+
+src_prepare() {
+ cmake_src_prepare
+
+ sed -i -e '/CMAKE_C_FLAGS/d' CMakeLists.txt || die
+}