summaryrefslogtreecommitdiff
path: root/media-libs/libplacebo/files/libplacebo-5.229.1-python-executable.patch
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libplacebo/files/libplacebo-5.229.1-python-executable.patch')
-rw-r--r--media-libs/libplacebo/files/libplacebo-5.229.1-python-executable.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/media-libs/libplacebo/files/libplacebo-5.229.1-python-executable.patch b/media-libs/libplacebo/files/libplacebo-5.229.1-python-executable.patch
new file mode 100644
index 000000000000..35486262c992
--- /dev/null
+++ b/media-libs/libplacebo/files/libplacebo-5.229.1-python-executable.patch
@@ -0,0 +1,11 @@
+Upstream bundles python deps and uses same interpreter as meson,
+but we don't and need this to use the eclass' python3 instead.
+
+https://bugs.gentoo.org/731728
+--- a/meson.build
++++ b/meson.build
+@@ -323,3 +323,3 @@
+ thirdparty = meson.project_source_root()/'3rdparty'
+-python = import('python').find_installation()
++python = import('python').find_installation('python3')
+ python_env = environment()