summaryrefslogtreecommitdiff
path: root/media-libs/libopenshot/libopenshot-0.2.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libopenshot/libopenshot-0.2.6.ebuild')
-rw-r--r--media-libs/libopenshot/libopenshot-0.2.6.ebuild17
1 files changed, 4 insertions, 13 deletions
diff --git a/media-libs/libopenshot/libopenshot-0.2.6.ebuild b/media-libs/libopenshot/libopenshot-0.2.6.ebuild
index af6f8eedbf89..87a124ff09ae 100644
--- a/media-libs/libopenshot/libopenshot-0.2.6.ebuild
+++ b/media-libs/libopenshot/libopenshot-0.2.6.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit cmake python-single-r1 toolchain-funcs
@@ -38,21 +38,12 @@ BDEPEND="doc? ( app-doc/doxygen )
dev-libs/unittest++
)"
-check_compiler() {
- if [[ ${MERGE_TYPE} != binary ]] && ! tc-has-openmp; then
- eerror "${P} requires a compiler with OpenMP support. Your current"
- eerror "compiler does not support it. If you use gcc, you can"
- eerror "re-emerge it with the 'openmp' use flag enabled."
- die "The current compiler does not support OpenMP"
- fi
-}
-
pkg_pretend() {
- check_compiler
+ [[ ${MERGE_TYPE} != binary ]] && tc-check-openmp
}
pkg_setup() {
- check_compiler
+ [[ ${MERGE_TYPE} != binary ]] && tc-check-openmp
use python && python-single-r1_pkg_setup
}