summaryrefslogtreecommitdiff
path: root/media-libs/liblastfm/files/liblastfm-1.1.0_pre20150206-cmake.patch
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/liblastfm/files/liblastfm-1.1.0_pre20150206-cmake.patch')
-rw-r--r--media-libs/liblastfm/files/liblastfm-1.1.0_pre20150206-cmake.patch97
1 files changed, 0 insertions, 97 deletions
diff --git a/media-libs/liblastfm/files/liblastfm-1.1.0_pre20150206-cmake.patch b/media-libs/liblastfm/files/liblastfm-1.1.0_pre20150206-cmake.patch
deleted file mode 100644
index a42baf0ca30e..000000000000
--- a/media-libs/liblastfm/files/liblastfm-1.1.0_pre20150206-cmake.patch
+++ /dev/null
@@ -1,97 +0,0 @@
-From 8703c12d7a177627fab4a2f67018d01cc7bf0808 Mon Sep 17 00:00:00 2001
-From: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
-Date: Sun, 1 Apr 2018 11:51:42 +0200
-Subject: [PATCH 1/3] Make Qt5 build default and simplify logic, add missing
- deps
-
----
- CMakeLists.txt | 10 +++-------
- 1 file changed, 3 insertions(+), 7 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index be88967..a8c81dd 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -27,16 +27,12 @@ set(CMAKE_MODULE_PATH "${CMAKE_MODULE_PATH}" "${PROJECT_SOURCE_DIR}/cmake/Module
- # setup qt stuff
- set(CMAKE_AUTOMOC ON)
-
--option(BUILD_WITH_QT4 "Build liblastfm with Qt4 no matter if Qt5 was found" OFF)
-+option(BUILD_WITH_QT4 "Build liblastfm with Qt4" OFF)
-
--if( NOT BUILD_WITH_QT4 )
-- # try Qt5 first, and prefer that if found
-- find_package(Qt5Core QUIET)
--endif()
-+if(NOT BUILD_WITH_QT4)
-+ find_package(Qt5 CONFIG REQUIRED Core Network Sql Xml)
-
--if(Qt5Core_DIR)
- set(LASTFM_LIB_VERSION_SUFFIX 5)
-- message(STATUS "Found Qt5! Please keep in mind, this is highly experimental and not our main development target..")
- include_directories(${Qt5Core_INCLUDE_DIRS})
- if(UNIX AND NOT APPLE)
- find_package(Qt5DBus REQUIRED)
---
-2.16.3
-
-
-From 22f6900552839bc90c0fc68b62707d42544eaccf Mon Sep 17 00:00:00 2001
-From: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
-Date: Sun, 1 Apr 2018 11:56:48 +0200
-Subject: [PATCH 2/3] Make use of FeatureSummary
-
----
- CMakeLists.txt | 3 +++
- 1 file changed, 3 insertions(+)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index a8c81dd..d5fd5b1 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -20,6 +20,7 @@ option(BUILD_TESTS "Build liblastfm tests" ON)
-
- # installation dirs
- include(GNUInstallDirs)
-+include(FeatureSummary)
-
- #cmake module path
- set(CMAKE_MODULE_PATH "${CMAKE_MODULE_PATH}" "${PROJECT_SOURCE_DIR}/cmake/Modules")
-@@ -93,3 +94,5 @@ if(BUILD_TESTS)
- enable_testing()
- add_subdirectory(tests)
- endif()
-+
-+feature_summary(WHAT ALL FATAL_ON_MISSING_REQUIRED_PACKAGES)
---
-2.16.3
-
-
-From bf3ee28f1aa5de7a3f3f5a3077adc97804e27b0e Mon Sep 17 00:00:00 2001
-From: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
-Date: Sun, 1 Apr 2018 12:06:48 +0200
-Subject: [PATCH 3/3] Cleanup include dirs
-
----
- CMakeLists.txt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index d5fd5b1..ef7fdd5 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -34,10 +34,10 @@ if(NOT BUILD_WITH_QT4)
- find_package(Qt5 CONFIG REQUIRED Core Network Sql Xml)
-
- set(LASTFM_LIB_VERSION_SUFFIX 5)
-- include_directories(${Qt5Core_INCLUDE_DIRS})
- if(UNIX AND NOT APPLE)
- find_package(Qt5DBus REQUIRED)
- endif()
-+ include_directories(Qt5::Core Qt5::Network Qt5::Xml)
-
- # macro(qt_wrap_ui)
- # qt5_wrap_ui(${ARGN})
---
-2.16.3
-