summaryrefslogtreecommitdiff
path: root/media-libs/libeot/libeot-0.01-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libeot/libeot-0.01-r1.ebuild')
-rw-r--r--media-libs/libeot/libeot-0.01-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/media-libs/libeot/libeot-0.01-r1.ebuild b/media-libs/libeot/libeot-0.01-r1.ebuild
new file mode 100644
index 000000000000..62bab11bf0a5
--- /dev/null
+++ b/media-libs/libeot/libeot-0.01-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Library for parsing Embedded OpenType files (Microsoft embedded font 'standard')"
+HOMEPAGE="https://github.com/umanwizard/libeot"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/umanwizard/libeot.git"
+else
+ SRC_URI="https://github.com/umanwizard/libeot/archive/v${PV}.tar.gz -> ${P}.tgz"
+ KEYWORDS="~amd64 ~riscv ~x86"
+fi
+
+LICENSE="MPL-2.0"
+SLOT="0"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}