summaryrefslogtreecommitdiff
path: root/media-libs/libcdr/libcdr-0.1.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libcdr/libcdr-0.1.6.ebuild')
-rw-r--r--media-libs/libcdr/libcdr-0.1.6.ebuild59
1 files changed, 0 insertions, 59 deletions
diff --git a/media-libs/libcdr/libcdr-0.1.6.ebuild b/media-libs/libcdr/libcdr-0.1.6.ebuild
deleted file mode 100644
index 1e277da8ed11..000000000000
--- a/media-libs/libcdr/libcdr-0.1.6.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-if [[ ${PV} = 9999 ]]; then
- EGIT_REPO_URI="https://anongit.freedesktop.org/git/libreoffice/libcdr.git"
- inherit autotools git-r3
-else
- SRC_URI="https://dev-www.libreoffice.org/src/libcdr/${P}.tar.xz"
- KEYWORDS="amd64 ~arm arm64 ~hppa ppc ppc64 ~sparc x86"
-fi
-
-DESCRIPTION="Library parsing the Corel cdr documents"
-HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libcdr"
-
-LICENSE="MPL-2.0"
-SLOT="0"
-IUSE="doc test"
-
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-libs/icu:=
- dev-libs/librevenge
- media-libs/lcms:2
- sys-libs/zlib
-"
-DEPEND="${RDEPEND}
- dev-libs/boost
-"
-BDEPEND="
- sys-devel/libtool
- virtual/pkgconfig
- doc? ( app-doc/doxygen )
- test? ( dev-util/cppunit )
-"
-
-PATCHES=( "${FILESDIR}/${P}-icu-68.patch" ) # bug 751934
-
-src_prepare() {
- default
- [[ -d m4 ]] || mkdir "m4"
- [[ ${PV} == 9999 ]] && eautoreconf
-}
-
-src_configure() {
- local myeconfargs=(
- --disable-static
- $(use_with doc docs)
- $(use_enable test tests)
- )
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
- find "${D}" -name '*.la' -delete || die
-}