summaryrefslogtreecommitdiff
path: root/media-libs/libcdaudio
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libcdaudio')
-rw-r--r--media-libs/libcdaudio/Manifest1
-rw-r--r--media-libs/libcdaudio/libcdaudio-0.99.12-r5.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/media-libs/libcdaudio/Manifest b/media-libs/libcdaudio/Manifest
index 10271092570a..807752cbaf55 100644
--- a/media-libs/libcdaudio/Manifest
+++ b/media-libs/libcdaudio/Manifest
@@ -4,4 +4,5 @@ AUX libcdaudio-0.99.12-libdir-fix.patch 343 BLAKE2B d53a60c2bfb6308fc9f54e61846b
AUX libcdaudio-0.99.12-m4-testprogram-fix.patch 176 BLAKE2B 9f17b18b06d418c49522b10f6f68b7a2b1d54aeac476482b091cd57e87d85c2d987b94b3582d410afbab7f6a3b1feab01e664c6aa3f9682da40c4cfae86a4aab SHA512 7a4907c583b2cf7022390f44480853a453132f8416940d6b3d3fc72c2a1c39633e9e7b1d268e7416d9dc5e6bd724bd1846d71869efe3acf0bae378676b1abc8f
DIST libcdaudio-0.99.12.tar.gz 357150 BLAKE2B 406dcdeb801237e9aa88934bd7ca39bad0b121641de198b65a4137ff1d25500954f12f7f86b78912098a7acda3afb188a5965b69e99ccb0a84441b3bf1931327 SHA512 c00fbea7776e847da93bfbf4cbe74ccb3ee826da80e74eef84575fc211729e6a09599f5bfa332c91d678a31f9de5e5b333bdafe51438f266f6dea519652f5247
EBUILD libcdaudio-0.99.12-r4.ebuild 667 BLAKE2B f1ea9e27c9bd40581c59179de01c90e28f56f37b6e8b7b89f5ed1fefa2e0827068dbd761948c1c952e2b9bdff10d553ada7a5438c5964d072aec4b49134586a7 SHA512 d1df15399736c70c889017d272152439e34d60a95e166130ac431427b32c95d0b53305796d9777c603c2ecae55fe39089f9be633003034afc5367b7af8fcd3bf
+EBUILD libcdaudio-0.99.12-r5.ebuild 1287 BLAKE2B ef43cf846fb1a5c7b1799b9b70702e7de6192dfde006f436ba609cf54c149b7a32a13ef3bf18da14b96a8525ee2c1081cd80f941eea4f287f89da45d0c3ceea2 SHA512 953a574b677141a566086eb97ee07afa25ec5985b70f67d6f256974684ff41a3ab4c3c3ea7ee7e29e5c1909e2d61343634b35f731a436c87e3c1524318b7b3b1
MISC metadata.xml 334 BLAKE2B d9be9083a98a2b39213e4be83809d0fc452d0ce36ac1d9f90a62ce46a921842daead9da5efc3fa677df8e8e6578f15d298f669a7a7c309d137716859e1420747 SHA512 5ed9828508c9cc4e02f337bb7acb844d418ff555372bc5bdb1650b3e8a366bb1ab2a2bac88a6e5b08b6b74e8f3dce119971b126cccfd329fb206b9358eb934a3
diff --git a/media-libs/libcdaudio/libcdaudio-0.99.12-r5.ebuild b/media-libs/libcdaudio/libcdaudio-0.99.12-r5.ebuild
new file mode 100644
index 000000000000..252b6d1402d8
--- /dev/null
+++ b/media-libs/libcdaudio/libcdaudio-0.99.12-r5.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="Library of cd audio related routines"
+HOMEPAGE="https://libcdaudio.sourceforge.net/"
+SRC_URI="mirror://sourceforge/libcdaudio/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.99-CAN-2005-0706.patch
+ "${FILESDIR}"/${P}-bug245649.patch
+ "${FILESDIR}"/${P}-libdir-fix.patch
+ "${FILESDIR}"/${P}-m4-testprogram-fix.patch
+)
+
+src_prepare() {
+ default
+
+ # replace vintage 2004 autotools collection complete with worrying
+ # code to "make it portable" by converting ANSI C into K&R C
+ sed -i '/AM_C_PROTOTYPES/d' configure.ac || die
+ sed -i '/ansi2knr/d' Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ # -Werror=lto-type-mismatch
+ #
+ # Upstream is pretty dead. The best that can be said is that as of a year
+ # ago if you posted support tickets, upstream would ask you:
+ #
+ # "libcdaudio is looking for a maintainer. Would you accept becoming a
+ # maintainer, so that you can integrate the change directly?"
+ filter-lto
+
+ econf --enable-threads --disable-static
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}