summaryrefslogtreecommitdiff
path: root/media-libs/libbsb/libbsb-0.0.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libbsb/libbsb-0.0.7.ebuild')
-rw-r--r--media-libs/libbsb/libbsb-0.0.7.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/media-libs/libbsb/libbsb-0.0.7.ebuild b/media-libs/libbsb/libbsb-0.0.7.ebuild
new file mode 100644
index 000000000000..94b0f2de5f81
--- /dev/null
+++ b/media-libs/libbsb/libbsb-0.0.7.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+DESCRIPTION="A portable C library for reading and writing BSB format image files"
+HOMEPAGE="http://libbsb.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="media-libs/libpng
+ media-libs/tiff"
+RDEPEND="${DEPEND}"
+
+# "make check" in 0.0.7 fails with newer tiff versions (4.0.0) altough the
+# tools work perfectly, so restrict test until this is fixed upstream
+RESTRICT="test"
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc README AUTHORS
+}