summaryrefslogtreecommitdiff
path: root/media-libs/lib3ds/lib3ds-1.3.0-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/lib3ds/lib3ds-1.3.0-r2.ebuild')
-rw-r--r--media-libs/lib3ds/lib3ds-1.3.0-r2.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/media-libs/lib3ds/lib3ds-1.3.0-r2.ebuild b/media-libs/lib3ds/lib3ds-1.3.0-r2.ebuild
index 22bfc9ac8e31..a2a9fdb2ba6c 100644
--- a/media-libs/lib3ds/lib3ds-1.3.0-r2.ebuild
+++ b/media-libs/lib3ds/lib3ds-1.3.0-r2.ebuild
@@ -1,11 +1,14 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit autotools
+
DESCRIPTION="library for managing 3D-Studio Release 3 and 4 .3DS files"
HOMEPAGE="https://code.google.com/p/lib3ds/"
SRC_URI="https://${PN}.googlecode.com/files/${P}.zip"
+
LICENSE="LGPL-2.1+"
SLOT="0"
KEYWORDS="amd64 ppc ppc64 x86"
@@ -18,6 +21,13 @@ PATCHES=(
"${FILESDIR}"/${P}-mesh.c.patch
)
+src_prepare() {
+ default
+
+ # Always eautoreconf to renew libtool (e.g. Clang)
+ eautoreconf
+}
+
src_configure() {
econf $(use_enable static-libs static)
}