summaryrefslogtreecommitdiff
path: root/media-libs/lensfun/lensfun-0.3.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/lensfun/lensfun-0.3.1.ebuild')
-rw-r--r--media-libs/lensfun/lensfun-0.3.1.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/media-libs/lensfun/lensfun-0.3.1.ebuild b/media-libs/lensfun/lensfun-0.3.1.ebuild
deleted file mode 100644
index 92566cc335f7..000000000000
--- a/media-libs/lensfun/lensfun-0.3.1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit multilib python-single-r1 cmake-utils
-
-DESCRIPTION="lensfun: A library for rectifying and simulating photographic lens distortions"
-HOMEPAGE="http://lensfun.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-3 CC-BY-SA-3.0" # See README for reasoning.
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
-IUSE="doc cpu_flags_x86_sse cpu_flags_x86_sse2 test"
-
-RDEPEND=">=dev-libs/glib-2.28
- media-libs/libpng:0=
- sys-libs/zlib:=
- ${PYTHON_DEPS}"
-DEPEND="${RDEPEND}
- doc? (
- app-doc/doxygen
- dev-python/docutils
- )"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DOCS=( README docs/mounts.txt ChangeLog )
-
-src_configure() {
- local mycmakeargs=(
- -DDOCDIR="${EPREFIX}"/usr/share/doc/${PF}/html
- -DLIBDIR="${EPREFIX}"/usr/$(get_libdir)
- -DBUILD_AUXFUN=ON
- $(cmake-utils_use_build doc)
- $(cmake-utils_use_build cpu_flags_x86_sse FOR_SSE)
- $(cmake-utils_use_build cpu_flags_x86_sse2 FOR_SSE2)
- $(cmake-utils_use_build test TESTS)
- -DBUILD_STATIC=OFF
- )
-
- cmake-utils_src_configure
-}