summaryrefslogtreecommitdiff
path: root/media-libs/jbig2dec
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/jbig2dec')
-rw-r--r--media-libs/jbig2dec/Manifest5
-rw-r--r--media-libs/jbig2dec/jbig2dec-0.19-r1.ebuild67
-rw-r--r--media-libs/jbig2dec/jbig2dec-0.19.ebuild6
-rw-r--r--media-libs/jbig2dec/jbig2dec-0.20.ebuild67
4 files changed, 141 insertions, 4 deletions
diff --git a/media-libs/jbig2dec/Manifest b/media-libs/jbig2dec/Manifest
index 432ea3a0e71b..bcb7a8ad352e 100644
--- a/media-libs/jbig2dec/Manifest
+++ b/media-libs/jbig2dec/Manifest
@@ -1,4 +1,7 @@
DIST jb2streams.zip 1285838 BLAKE2B 9a2b6047a7b970439693d6f5fdefb9488019a562e7f831288b27df09bb19dec2f84854cf7fea50b5b041d331e925145f37f2f89848058ecdc074e7d6c238033f SHA512 382890b36345b8aaebb3554e776a53f3276c6d835335ce41f3f41829ff62bba7ae646602544103ba8541a7a824dca92d682b682c254ab2918c7fe45b3e358b45
DIST jbig2dec-0.19.tar.gz 149134 BLAKE2B 576f3a516499b6291d25dfdefe5af62899665167526dca11435bc07e04a3feb707f82d3a8bdda774f5cfe0d792c3147e77aa94fa57feac25ba1c0a7805c5fc58 SHA512 d5a27951cc9c06c184f454e258e81b6e4d5aa2742a4da821522b9a42ecc78e7e1b78058dabc23821618e62d62d8832011f16b5ef2d66beac463da6b809fd02af
-EBUILD jbig2dec-0.19.ebuild 1502 BLAKE2B 2a40291807a1097797d88aadd2543a3d48dfac829e408299a363fd9c5762358f6086e2a8ce3c904817ad460785d2799af8af4c119aca34163be81eb378b84d84 SHA512 462a3e268ce7d6fc8110d6ae09eed80cb316aa8da5353257fabda9488a48ca3fae80685a666a0f636c7994c23e389a3c08d2a4f76c30146c79b51c83b375830f
+DIST jbig2dec-0.20.tar.gz 149782 BLAKE2B 6e5a26b736bbc5dc25614e192855d74a59337f5e5aa82cd0882e42a34259295d7df7f8c7acfb88b53ac3817141459c6d6cc58c0d36c1c341e2afedbed8f7d83d SHA512 8b8a28b93b23e4284ca229e6c8935fd161ce5c597f7470a46ec06a3241d0ac23cf921aecdd4e0c1bd3c904591409054236f2ce25b6d8ae40db742559c7f4dbe9
+EBUILD jbig2dec-0.19-r1.ebuild 1512 BLAKE2B c05ac93f838135771088f893c511fe43e1050eca2f5443dee8c76f302c0695b1072626139806a855473117c6ffab15d7de05ae82f2f4672f32d52172b1fe4c56 SHA512 603d11524cfc9f865646db23038b618cbf069d383e48373ef019031c404d7ec24a3ed9d120893a3b8da579a9d53c8305955eaa5d5fc0a8d83a5d571ae7ca6b35
+EBUILD jbig2dec-0.19.ebuild 1504 BLAKE2B d12286cdd097af8f3af42ece3a96445821d45e0ff38f759f9fb106eca86db9bb45033dd155d35decaa047aebd8c869d3a71ce807b947a03b9c2a941f13a513c6 SHA512 957bde227033082ce14be1f5e0d9aeef4ddcf4f83d5d0ce5f36a3d2b3a8d2c708e6e1db64b982c4f58f1e14bae3f8438cc23c27a32e7feb9c554cefc6d436684
+EBUILD jbig2dec-0.20.ebuild 1512 BLAKE2B c05ac93f838135771088f893c511fe43e1050eca2f5443dee8c76f302c0695b1072626139806a855473117c6ffab15d7de05ae82f2f4672f32d52172b1fe4c56 SHA512 603d11524cfc9f865646db23038b618cbf069d383e48373ef019031c404d7ec24a3ed9d120893a3b8da579a9d53c8305955eaa5d5fc0a8d83a5d571ae7ca6b35
MISC metadata.xml 414 BLAKE2B cae9b25dd53d68c263a4afe3c1a18c02923fd665b60791df7d0b9b55d82184159c5c1ced1786bd443d38668b1f12b083191cb1da4e9a576c5da5e4d36828d56c SHA512 1e5bcded3676b4d336781551dcd875e1d7cc5532eaf13cbf013799c225f94967c8f592707492cf8908a65d76e473452fa5b0419fbaea73f1c718660e65ffdcba
diff --git a/media-libs/jbig2dec/jbig2dec-0.19-r1.ebuild b/media-libs/jbig2dec/jbig2dec-0.19-r1.ebuild
new file mode 100644
index 000000000000..32d59d523ce2
--- /dev/null
+++ b/media-libs/jbig2dec/jbig2dec-0.19-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+inherit autotools python-any-r1
+
+DESCRIPTION="A decoder implementation of the JBIG2 image compression format"
+HOMEPAGE="https://jbig2dec.com/"
+SRC_URI="
+ https://github.com/ArtifexSoftware/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
+ test? ( https://jbig2dec.sourceforge.net/ubc/jb2streams.zip )
+"
+
+LICENSE="AGPL-3"
+SLOT="0/$(ver_cut 1-2)" #698428
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="png static-libs test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ app-arch/unzip
+ ${PYTHON_DEPS}
+ )
+"
+RDEPEND="png? ( media-libs/libpng:= )"
+DEPEND="${RDEPEND}"
+
+DOCS=( CHANGES README )
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ if use test; then
+ mkdir "${WORKDIR}/ubc" || die
+ mv -v "${WORKDIR}"/*.jb2 "${WORKDIR}/ubc/" || die
+ mv -v "${WORKDIR}"/*.bmp "${WORKDIR}/ubc/" || die
+ fi
+
+ # We only need configure.ac and config_types.h.in
+ sed -i \
+ -e '/^# do we need automake?/,/^autoheader/d' \
+ -e '/echo " $AUTOM.*/,$d' \
+ autogen.sh \
+ || die "failed to modify autogen.sh"
+
+ ./autogen.sh || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_with png libpng)
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -exec rm {} + || die
+}
diff --git a/media-libs/jbig2dec/jbig2dec-0.19.ebuild b/media-libs/jbig2dec/jbig2dec-0.19.ebuild
index 315beae29304..9b7fa7056477 100644
--- a/media-libs/jbig2dec/jbig2dec-0.19.ebuild
+++ b/media-libs/jbig2dec/jbig2dec-0.19.ebuild
@@ -1,16 +1,16 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..13} )
inherit autotools python-any-r1
DESCRIPTION="A decoder implementation of the JBIG2 image compression format"
HOMEPAGE="https://jbig2dec.com/"
SRC_URI="
https://github.com/ArtifexSoftware/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
- test? ( http://jbig2dec.sourceforge.net/ubc/jb2streams.zip )
+ test? ( https://jbig2dec.sourceforge.net/ubc/jb2streams.zip )
"
LICENSE="AGPL-3"
diff --git a/media-libs/jbig2dec/jbig2dec-0.20.ebuild b/media-libs/jbig2dec/jbig2dec-0.20.ebuild
new file mode 100644
index 000000000000..32d59d523ce2
--- /dev/null
+++ b/media-libs/jbig2dec/jbig2dec-0.20.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+inherit autotools python-any-r1
+
+DESCRIPTION="A decoder implementation of the JBIG2 image compression format"
+HOMEPAGE="https://jbig2dec.com/"
+SRC_URI="
+ https://github.com/ArtifexSoftware/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
+ test? ( https://jbig2dec.sourceforge.net/ubc/jb2streams.zip )
+"
+
+LICENSE="AGPL-3"
+SLOT="0/$(ver_cut 1-2)" #698428
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="png static-libs test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ app-arch/unzip
+ ${PYTHON_DEPS}
+ )
+"
+RDEPEND="png? ( media-libs/libpng:= )"
+DEPEND="${RDEPEND}"
+
+DOCS=( CHANGES README )
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ if use test; then
+ mkdir "${WORKDIR}/ubc" || die
+ mv -v "${WORKDIR}"/*.jb2 "${WORKDIR}/ubc/" || die
+ mv -v "${WORKDIR}"/*.bmp "${WORKDIR}/ubc/" || die
+ fi
+
+ # We only need configure.ac and config_types.h.in
+ sed -i \
+ -e '/^# do we need automake?/,/^autoheader/d' \
+ -e '/echo " $AUTOM.*/,$d' \
+ autogen.sh \
+ || die "failed to modify autogen.sh"
+
+ ./autogen.sh || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_with png libpng)
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -exec rm {} + || die
+}