summaryrefslogtreecommitdiff
path: root/media-libs/intel-mediasdk
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/intel-mediasdk')
-rw-r--r--media-libs/intel-mediasdk/Manifest3
-rw-r--r--media-libs/intel-mediasdk/intel-mediasdk-23.2.2.ebuild11
-rw-r--r--media-libs/intel-mediasdk/intel-mediasdk-9999.ebuild86
3 files changed, 10 insertions, 90 deletions
diff --git a/media-libs/intel-mediasdk/Manifest b/media-libs/intel-mediasdk/Manifest
index ad2e44aedc9a..2cf34f5d408d 100644
--- a/media-libs/intel-mediasdk/Manifest
+++ b/media-libs/intel-mediasdk/Manifest
@@ -1,5 +1,4 @@
AUX intel-mediasdk-23.2.0-gcc13.patch 336 BLAKE2B beaea84539f84540be73863d2bafb8fe1f4b33c1c3d5d82c5480ab990cd64267e2a3c05fc4b5001c84fcfec565de16379ff1c440330f46971273dd349c265444 SHA512 fe7bbe6b62b775127d4550d997c7b27631416f6d136a71eb11d4bd589d42db5a2a41d275d72f23f0c14d29aa0de2764cf828542771e5a1e2fcb1acf16fc8524d
DIST intel-mediasdk-23.2.2.tar.gz 22527304 BLAKE2B aa0e7b0fabc1bd376511a1022da5e40ea282c4f016384e8bc20fb4e28693e3bb06816ad790da1a708f623ac3a6e6b2f704f785dd4e6cd5c9db320f63c8bded78 SHA512 d4cfebee4f689b93c0171775ff2bab449f801c55822c5b800fe3217653d197216cf2a95dea115cf51f308e158adea7a271f03081b011e024c16bf7915fdcd586
-EBUILD intel-mediasdk-23.2.2.ebuild 2134 BLAKE2B 1acd2c39cb8e02c1feaa155daf607e8a211b6cd1b890f5919e7b619df639f5c4f55efebb205a720177235abe95bdf410db33633fb2a3788e9e039da03030da85 SHA512 7f0c38ab2ea12e8efbf4c178e7a795593fb995f03b2d68138b6314a69dbeec255c598db70374836182f341155f03f5ae93d49a3632c460dae190ddca7b257f17
-EBUILD intel-mediasdk-9999.ebuild 2024 BLAKE2B f935f5a5bd9cc42db08ca3430ed1fba806cab08cafc8be1bfbdc202f29f93daf565ffe929a9f4842085b47d27672336b153d738dd1e252a9fdc897b50575a950 SHA512 f311ed3e54a0ec6cee30826a68dc75588effe77a691e622cef335b4e63044e6678b8198e20899904871f8f2fa64ccddb22bf6823b5739737378f1c1304295965
+EBUILD intel-mediasdk-23.2.2.ebuild 2242 BLAKE2B 5a2e3366c1e341812da75619407d031dd7517bba39d77498ef6c81e6c5ef9efee3ddc284ecaf226b4458c3d412287c3d7b2f50998243fa799cf09b6098cdf82a SHA512 e20dc4b14afb11b691991ed84b1ad45cf6b3cda53ca182addd10ea5d964f3776295a7ff296a871a8a86a8d53111bf6576760457b11c89e0809c4485cc608294e
MISC metadata.xml 507 BLAKE2B 1e08efd32142406ac7fc4390a10f51b117bbaf56fc2006ed508bf026d2720447a782f2e86ba323017dc6388ca18e4743688eaf1a8fb7165bc6377194b4139d0b SHA512 ef8d11178dcded14cb74c49e01bedde8986ff8aa02641c275d5a36ca3973782955f90d0c25ef728ca120fc1a46f1f3965f4b5a36376203c6f6cb9b1411af52e1
diff --git a/media-libs/intel-mediasdk/intel-mediasdk-23.2.2.ebuild b/media-libs/intel-mediasdk/intel-mediasdk-23.2.2.ebuild
index a0674e307b13..b1ee6951b88c 100644
--- a/media-libs/intel-mediasdk/intel-mediasdk-23.2.2.ebuild
+++ b/media-libs/intel-mediasdk/intel-mediasdk-23.2.2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit cmake-multilib optfeature
+inherit cmake-multilib flag-o-matic optfeature
if [[ ${PV} == *9999 ]] ; then
: ${EGIT_REPO_URI:="https://github.com/Intel-Media-SDK/MediaSDK"}
@@ -65,6 +65,13 @@ PATCHES=(
"${FILESDIR}/${PN}-23.2.0-gcc13.patch"
)
+src_configure() {
+ # ODR violation (bug #924366)
+ filter-lto
+
+ cmake-multilib_src_configure
+}
+
multilib_src_configure() {
local mycmakeargs=(
# OpenCL only has an effect if we build kernels
diff --git a/media-libs/intel-mediasdk/intel-mediasdk-9999.ebuild b/media-libs/intel-mediasdk/intel-mediasdk-9999.ebuild
deleted file mode 100644
index 61173b80745c..000000000000
--- a/media-libs/intel-mediasdk/intel-mediasdk-9999.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake-multilib optfeature
-
-if [[ ${PV} == *9999 ]] ; then
- : ${EGIT_REPO_URI:="https://github.com/Intel-Media-SDK/MediaSDK"}
- if [[ ${PV%9999} != "" ]] ; then
- : ${EGIT_BRANCH:="release/${PV%.9999}"}
- fi
- inherit git-r3
-fi
-
-DESCRIPTION="Intel Media SDK"
-HOMEPAGE="https://github.com/Intel-Media-SDK/MediaSDK"
-if [[ ${PV} == *9999 ]] ; then
- SRC_URI=""
-else
- SRC_URI="https://github.com/Intel-Media-SDK/MediaSDK/archive/intel-mediasdk-${PV}.tar.gz"
- S="${WORKDIR}/MediaSDK-intel-mediasdk-${PV}"
- KEYWORDS="~amd64"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-
-IUSE="dri test tools wayland X"
-# Test not working at the moment
-#RESTRICT="!test? ( test )"
-RESTRICT="test"
-REQUIRED_USE="
- dri? ( X )
-"
-
-# x11-libs/libdrm[video_cards_intel] for intel_bufmgr.h in samples
-# bug #805224
-RDEPEND="
- x11-libs/libpciaccess[${MULTILIB_USEDEP}]
- >=media-libs/libva-intel-media-driver-${PV}[${MULTILIB_USEDEP}]
- media-libs/libva[X?,wayland?,${MULTILIB_USEDEP}]
- x11-libs/libdrm[video_cards_intel,${MULTILIB_USEDEP}]
- wayland? (
- dev-libs/wayland[${MULTILIB_USEDEP}]
- )
- X? (
- x11-libs/libX11[${MULTILIB_USEDEP}]
- x11-libs/libxcb[${MULTILIB_USEDEP}]
- )
-"
-DEPEND="${RDEPEND}
- wayland? (
- dev-libs/wayland-protocols
- )
-"
-BDEPEND="
- wayland? (
- dev-util/wayland-scanner
- )
-"
-
-multilib_src_configure() {
- local mycmakeargs=(
- # OpenCL only has an effect if we build kernels
- -DENABLE_OPENCL=OFF
- -DBUILD_TUTORIALS=OFF
- # Need to package the cm-compiler to build kernels, use pre-built instead
- -DBUILD_KERNELS=OFF
- -DBUILD_RUNTIME=ON
- -DBUILD_DISPATCHER=ON
- -DBUILD_TOOLS="$(usex tools)"
- # Cannot build tools without samples
- -DBUILD_SAMPLES="$(usex tools)"
- -DBUILD_TESTS="$(usex test)"
- -DENABLE_X11="$(usex X)"
- -DENABLE_X11_DRI3="$(usex dri)"
- -DENABLE_WAYLAND="$(usex wayland)"
- )
-
- cmake_src_configure
-}
-
-pkg_postinst() {
- optfeature "Intel GPUs newer then, and including, Intel Xe" media-libs/oneVPL-intel-gpu
-}