summaryrefslogtreecommitdiff
path: root/media-libs/gst-rtsp-server/gst-rtsp-server-1.22.11.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/gst-rtsp-server/gst-rtsp-server-1.22.11.ebuild')
-rw-r--r--media-libs/gst-rtsp-server/gst-rtsp-server-1.22.11.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/media-libs/gst-rtsp-server/gst-rtsp-server-1.22.11.ebuild b/media-libs/gst-rtsp-server/gst-rtsp-server-1.22.11.ebuild
new file mode 100644
index 000000000000..85cf45dde01e
--- /dev/null
+++ b/media-libs/gst-rtsp-server/gst-rtsp-server-1.22.11.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gstreamer-meson
+
+DESCRIPTION="A GStreamer based RTSP server"
+HOMEPAGE="https://gstreamer.freedesktop.org/modules/gst-rtsp-server.html"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="examples +introspection static-libs"
+
+# gst-plugins-base for many used elements and API
+# gst-plugins-good for rtprtxsend and rtpbin elements, maybe more
+# gst-plugins-srtp for srtpenc and srtpdec elements
+RDEPEND="
+ >=media-libs/gstreamer-${PV}:${SLOT}[introspection?,${MULTILIB_USEDEP}]
+ >=media-libs/gst-plugins-base-${PV}:${SLOT}[introspection?,${MULTILIB_USEDEP}]
+ >=media-libs/gst-plugins-good-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+ >=media-plugins/gst-plugins-srtp-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-1.31.1:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND=""
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dintrospection=$(multilib_native_usex introspection enabled disabled)
+ )
+
+ gstreamer_multilib_src_configure
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ if use examples ; then
+ docinto examples
+ dodoc "${S}"/examples/*.c
+ fi
+}