summaryrefslogtreecommitdiff
path: root/media-libs/gexiv2/gexiv2-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/gexiv2/gexiv2-9999.ebuild')
-rw-r--r--media-libs/gexiv2/gexiv2-9999.ebuild31
1 files changed, 15 insertions, 16 deletions
diff --git a/media-libs/gexiv2/gexiv2-9999.ebuild b/media-libs/gexiv2/gexiv2-9999.ebuild
index 91c86ef6de69..c83cec2f56ad 100644
--- a/media-libs/gexiv2/gexiv2-9999.ebuild
+++ b/media-libs/gexiv2/gexiv2-9999.ebuild
@@ -3,9 +3,9 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{5,6} )
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
-inherit meson python-r1 vala xdg-utils
+inherit meson python-r1 vala
DESCRIPTION="GObject-based wrapper around the Exiv2 library"
HOMEPAGE="https://wiki.gnome.org/Projects/gexiv2"
@@ -15,25 +15,19 @@ if [[ ${PV} == 9999 ]]; then
inherit git-r3
else
SRC_URI="mirror://gnome/sources/${PN}/$(ver_cut 1-2)/${P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
fi
-LICENSE="LGPL-2.1"
+LICENSE="LGPL-2.1+ GPL-2"
SLOT="0"
-IUSE="gtk-doc +introspection python static-libs test vala"
-
+IUSE="gtk-doc +introspection python static-libs test +vala"
REQUIRED_USE="
python? ( introspection ${PYTHON_REQUIRED_USE} )
test? ( python introspection )
vala? ( introspection )
"
+RESTRICT="!test? ( test )"
-RDEPEND="${PYTHON_DEPS}
- >=dev-libs/glib-2.38.0:2
- >=media-gfx/exiv2-0.21:=
- introspection? ( >=dev-libs/gobject-introspection-1.54:= )
-"
-DEPEND="${RDEPEND}"
BDEPEND="
dev-util/glib-utils
virtual/pkgconfig
@@ -44,11 +38,16 @@ BDEPEND="
)
vala? ( $(vala_depend) )
"
+RDEPEND="${PYTHON_DEPS}
+ >=dev-libs/glib-2.38.0:2
+ >=media-gfx/exiv2-0.21:=
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+DEPEND="${RDEPEND}"
src_prepare() {
- xdg_environment_reset
- use vala && vala_src_prepare
default
+ use vala && vala_src_prepare
}
src_configure() {
@@ -56,8 +55,8 @@ src_configure() {
$(meson_use introspection)
$(meson_use vala vapi)
$(meson_use gtk-doc gtk_doc)
- # prevents installation of python modules (uses install_data from meson
- # which does not optimize the modules
+ # Prevents installation of python modules (uses install_data from meson
+ # which does not optimize the modules)
-Dpython2_girdir=no
-Dpython3_girdir=no
)