summaryrefslogtreecommitdiff
path: root/media-libs/gd/files
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/gd/files')
-rw-r--r--media-libs/gd/files/gd-2.3.0-fix-tests-bug722448.patch62
-rw-r--r--media-libs/gd/files/gd-2.3.0-getlib.patch81
2 files changed, 0 insertions, 143 deletions
diff --git a/media-libs/gd/files/gd-2.3.0-fix-tests-bug722448.patch b/media-libs/gd/files/gd-2.3.0-fix-tests-bug722448.patch
deleted file mode 100644
index eef62fca676b..000000000000
--- a/media-libs/gd/files/gd-2.3.0-fix-tests-bug722448.patch
+++ /dev/null
@@ -1,62 +0,0 @@
-From ec0b4397698bd358557d33641aac4beb1912f43b Mon Sep 17 00:00:00 2001
-From: wilson chen <willson.chenwx@gmail.com>
-Date: Wed, 15 Apr 2020 00:25:01 +0800
-Subject: [PATCH] Improve test cases for gdImageString16 and gdImageStringUp16
- (#625)
-
-Fixed #623. wchar_t is 32 bits on 64-bits AIX, which will result in test case failure.
-So we replace wchar_t with unsigned short array.
----
- tests/gdimagestring16/gdimagestring16.c | 6 ++----
- tests/gdimagestringup16/gdimagestringup16.c | 6 ++----
- 2 files changed, 4 insertions(+), 8 deletions(-)
-
-diff --git a/tests/gdimagestring16/gdimagestring16.c b/tests/gdimagestring16/gdimagestring16.c
-index 57eae978..0ca06680 100644
---- a/tests/gdimagestring16/gdimagestring16.c
-+++ b/tests/gdimagestring16/gdimagestring16.c
-@@ -9,9 +9,7 @@ int main()
- {
- /* Declare the image */
- gdImagePtr im = NULL;
-- wchar_t *wchr = L"H";
-- unsigned short *sptr;
-- sptr = (unsigned short *)wchr;
-+ unsigned short s[2] = {'H', 0};
- int foreground;
- int errorcode = 0;
- gdFontPtr fontptr = gdFontGetLarge();
-@@ -20,7 +18,7 @@ int main()
- gdImageColorAllocate(im, 255, 255, 255);
- foreground = gdImageColorAllocate(im, 22, 4, 238);
-
-- gdImageString16(im, fontptr, 2, 2, sptr, foreground);
-+ gdImageString16(im, fontptr, 2, 2, s, foreground);
-
- if (!gdAssertImageEqualsToFile("gdimagestring16/gdimagestring16_exp.png", im))
- errorcode = 1;
-diff --git a/tests/gdimagestringup16/gdimagestringup16.c b/tests/gdimagestringup16/gdimagestringup16.c
-index c843abec..c24639fd 100644
---- a/tests/gdimagestringup16/gdimagestringup16.c
-+++ b/tests/gdimagestringup16/gdimagestringup16.c
-@@ -9,9 +9,7 @@ int main()
- {
- /* Declare the image */
- gdImagePtr im = NULL;
-- wchar_t *wchr = L"H";
-- unsigned short *sptr;
-- sptr = (unsigned short *)wchr;
-+ unsigned short s[2] = {'H', 0};
- int foreground;
- int errorcode = 0;
- gdFontPtr fontptr = gdFontGetLarge();
-@@ -20,7 +18,7 @@ int main()
- gdImageColorAllocate(im, 255, 255, 255);
- foreground = gdImageColorAllocate(im, 22, 4, 238);
-
-- gdImageStringUp16(im, fontptr, 2, 18, sptr, foreground);
-+ gdImageStringUp16(im, fontptr, 2, 18, s, foreground);
-
- if (!gdAssertImageEqualsToFile("gdimagestringup16/gdimagestringup16_exp.png", im))
- errorcode = 1;
-
diff --git a/media-libs/gd/files/gd-2.3.0-getlib.patch b/media-libs/gd/files/gd-2.3.0-getlib.patch
deleted file mode 100644
index 91884e93292d..000000000000
--- a/media-libs/gd/files/gd-2.3.0-getlib.patch
+++ /dev/null
@@ -1,81 +0,0 @@
-From 635dd9a3065ed88e1741e6b963044b80e913f96a Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Tue, 24 Mar 2020 08:01:01 +0100
-Subject: [PATCH] distribute getlib.sh
-
----
- config/Makefile.am | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/config/Makefile.am b/config/Makefile.am
-index 122287ee..6416dda4 100644
---- a/config/Makefile.am
-+++ b/config/Makefile.am
-@@ -1,5 +1,5 @@
- ## Process this file with automake to produce Makefile.in -*-Makefile-*-
--EXTRA_DIST = gdlib.pc.cmake gdlib.pc.in getver.pl
-+EXTRA_DIST = gdlib.pc.cmake gdlib.pc.in getlib.sh getver.pl
-
- pkgconfigdir = $(libdir)/pkgconfig
- pkgconfig_DATA = gdlib.pc
-
-diff -ruN a/config/getlib.sh b/config/getlib.sh
---- a/config/getlib.sh 1970-01-01 00:00:00.000000000 -0000
-+++ b/config/getlib.sh 2020-05-05 17:37:31.638896089 -0000
-@@ -0,0 +1,43 @@
-+#!/bin/sh
-+
-+GETVER="${0%/*}/getver.pl"
-+GDLIB_MAJOR=$("${GETVER}" MAJOR)
-+GDLIB_MINOR=$("${GETVER}" MINOR)
-+GDLIB_REVISION=$("${GETVER}" RELEASE)
-+
-+# Dynamic library version information
-+# See http://www.gnu.org/software/libtool/manual/libtool.html#Updating-version-info
-+
-+GDLIB_LT_CURRENT=3
-+# This is the version where the soname (current above) changes. We use it
-+# to reset the revision base back to zero. It's a bit of a pain, but some
-+# systems restrict the revision range below to [0..255] (like OS X).
-+GDLIB_PREV_MAJOR=2
-+GDLIB_PREV_MINOR=2
-+# This isn't 100% correct, but it tends to be a close enough approximation
-+# for how we manage the codebase. It's rare to do a release that doesn't
-+# modify the library since this project is centered around the library.
-+GDLIB_LT_REVISION=$(( ((GDLIB_MAJOR - GDLIB_PREV_MAJOR) << 6) | ((GDLIB_MINOR - GDLIB_PREV_MINOR) << 3) | GDLIB_REVISION ))
-+GDLIB_LT_AGE=0
-+
-+# The first three fields we feed into libtool and the OS target determines how
-+# they get used. The last two fields we feed into cmake. We use the same rules
-+# as Linux SONAME versioning in libtool, but cmake should handle it for us.
-+case $1 in
-+CURRENT)
-+ printf '%s' "${GDLIB_LT_CURRENT}"
-+ ;;
-+REVISION)
-+ printf '%s' "${GDLIB_LT_REVISION}"
-+ ;;
-+AGE)
-+ printf '%s' "${GDLIB_LT_AGE}"
-+ ;;
-+VERSION)
-+ printf '%s' "$(( GDLIB_LT_CURRENT - GDLIB_LT_AGE )).${GDLIB_LT_AGE}.${GDLIB_LT_REVISION}"
-+ ;;
-+SONAME)
-+ printf '%s' "$(( GDLIB_LT_CURRENT - GDLIB_LT_AGE ))"
-+ ;;
-+esac
-+
-diff --git a/configure.ac b/configure.ac
-index 8996053..86d0bc9 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -20,7 +20,7 @@ AC_CANONICAL_HOST
-
- dnl Keep the libtool version details in an external script so cmake can
- dnl access the values too.
--define([lt_gv], [config/getlib.sh ]$1)
-+define([lt_gv], [${SHELL} config/getlib.sh ]$1)
- m4_define([gd_LT_CURRENT], esyscmd(lt_gv(CURRENT)))
- m4_define([gd_LT_REVISION], esyscmd(lt_gv(REVISION)))
- m4_define([gd_LT_AGE], esyscmd(lt_gv(AGE)))