summaryrefslogtreecommitdiff
path: root/media-libs/freetype/freetype-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/freetype/freetype-9999.ebuild')
-rw-r--r--media-libs/freetype/freetype-9999.ebuild15
1 files changed, 12 insertions, 3 deletions
diff --git a/media-libs/freetype/freetype-9999.ebuild b/media-libs/freetype/freetype-9999.ebuild
index ba2ddfe1a614..f8e4fb37a31a 100644
--- a/media-libs/freetype/freetype-9999.ebuild
+++ b/media-libs/freetype/freetype-9999.ebuild
@@ -28,7 +28,7 @@ RESTRICT="!bindist? ( bindist )" # bug 541408
RDEPEND=">=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
bzip2? ( >=app-arch/bzip2-1.0.6-r4[${MULTILIB_USEDEP}] )
- harfbuzz? ( >=media-libs/harfbuzz-0.9.19[truetype,${MULTILIB_USEDEP}] )
+ harfbuzz? ( >=media-libs/harfbuzz-1.3.0[truetype,${MULTILIB_USEDEP}] )
png? ( >=media-libs/libpng-1.2.51:0=[${MULTILIB_USEDEP}] )
utils? (
X? (
@@ -49,7 +49,7 @@ PATCHES=(
)
_egit_repo_handler() {
- if [[ "${PV}" = 9999 ]] ; then
+ if [[ "${PV}" == 9999 ]] ; then
local phase="${1}"
case ${phase} in
fetch|unpack)
@@ -82,7 +82,7 @@ src_unpack() {
}
src_prepare() {
- if [[ "${PV}" = 9999 ]] ; then
+ if [[ "${PV}" == 9999 ]] ; then
# inspired by shipped autogen.sh script
eval $(sed -nf version.sed include/freetype/freetype.h)
pushd builds/unix &>/dev/null || die
@@ -162,6 +162,7 @@ multilib_src_configure() {
type -P gmake &> /dev/null && export GNUMAKE=gmake
local myeconfargs=(
+ --disable-freetype-config
--enable-biarch-config
--enable-shared
$(use_with bzip2)
@@ -174,6 +175,13 @@ multilib_src_configure() {
LIBPNG_LDFLAGS="$($(tc-getPKG_CONFIG) --libs libpng)"
)
+ case ${CHOST} in
+ mingw*|*-mingw*) ;;
+ # Workaround windows mis-detection: bug #654712
+ # Have to do it for both ${CHOST}-windres and windres
+ *) myeconfargs+=( ac_cv_prog_RC= ac_cv_prog_ac_ct_RC= ) ;;
+ esac
+
ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
}
@@ -195,6 +203,7 @@ multilib_src_install() {
if multilib_is_native_abi && use utils; then
einfo "Installing utils"
rm "${WORKDIR}"/ft2demos-${PV}/bin/README || die
+ dodir /usr/bin #654780
local ft2demo
for ft2demo in ../ft2demos-${PV}/bin/*; do
./libtool --mode=install $(type -P install) -m 755 "$ft2demo" \