summaryrefslogtreecommitdiff
path: root/media-libs/chromaprint/chromaprint-1.5.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/chromaprint/chromaprint-1.5.0.ebuild')
-rw-r--r--media-libs/chromaprint/chromaprint-1.5.0.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/media-libs/chromaprint/chromaprint-1.5.0.ebuild b/media-libs/chromaprint/chromaprint-1.5.0.ebuild
deleted file mode 100644
index 67c9ef1d4a79..000000000000
--- a/media-libs/chromaprint/chromaprint-1.5.0.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-CMAKE_ECLASS=cmake
-GTEST_VERSION="1.10.0"
-GTEST_DIR_VERSION="1.10.x"
-inherit cmake-multilib
-
-DESCRIPTION="Library implementing a custom algorithm for extracting audio fingerprints"
-HOMEPAGE="https://acoustid.org/chromaprint"
-SRC_URI="https://github.com/acoustid/${PN}/releases/download/v${PV}/${P}.tar.gz
- test? ( https://github.com/google/googletest/archive/v$(ver_cut 1-2 ${GTEST_VERSION}).x.tar.gz -> gtest-${GTEST_VERSION}.tar.gz )
-"
-
-LICENSE="LGPL-2.1"
-SLOT="0/1"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv sparc x86"
-IUSE="test tools"
-RESTRICT="!test? ( test )"
-
-# note: use ffmpeg instead of fftw because it's recommended and required for tools
-RDEPEND=">=media-video/ffmpeg-2.6:0=[${MULTILIB_USEDEP}]
-"
-DEPEND="${RDEPEND}
- test? ( dev-cpp/gtest[${MULTILIB_USEDEP}] )"
-
-DOCS=( NEWS.txt README.md )
-
-S="${WORKDIR}/${PN}-v${PV}"
-
-multilib_src_configure() {
- export GTEST_ROOT="${WORKDIR}/googletest-${GTEST_DIR_VERSION}/googletest/"
- local mycmakeargs=(
- -DBUILD_TOOLS=$(multilib_native_usex tools ON OFF)
- -DBUILD_TESTS=$(usex test ON OFF)
- -DFFT_LIB=avfft
- -DAUDIO_PROCESSOR_LIB="swresample"
- )
- cmake_src_configure
-}
-
-multilib_src_test() {
- cd tests && (./all_tests || die "Tests failed")
-}