summaryrefslogtreecommitdiff
path: root/media-libs/chromaprint/chromaprint-1.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/chromaprint/chromaprint-1.2.ebuild')
-rw-r--r--media-libs/chromaprint/chromaprint-1.2.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/media-libs/chromaprint/chromaprint-1.2.ebuild b/media-libs/chromaprint/chromaprint-1.2.ebuild
deleted file mode 100644
index e6bff8e54792..000000000000
--- a/media-libs/chromaprint/chromaprint-1.2.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit cmake-utils
-
-DESCRIPTION="A client-side library that implements a custom algorithm for extracting fingerprints"
-HOMEPAGE="https://acoustid.org/chromaprint"
-SRC_URI="https://bitbucket.org/acoustid/${PN}/downloads/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~ppc ~ppc64 x86 ~amd64-fbsd"
-IUSE="libav test tools"
-
-# note: use ffmpeg or libav instead of fftw because it's recommended and required for tools
-RDEPEND="
- libav? ( media-video/libav:0= )
- !libav? ( >=media-video/ffmpeg-2.6:0= )
-"
-DEPEND="${RDEPEND}
- test? (
- dev-cpp/gtest
- dev-libs/boost
- )"
-
-DOCS="NEWS.txt README.md"
-
-PATCHES=( "${FILESDIR}"/${PN}-1.1-gtest.patch "${FILESDIR}"/${P}-ffmpeg29.patch )
-
-src_configure() {
- local mycmakeargs=(
- $(cmake-utils_use_build tools EXAMPLES)
- $(cmake-utils_use_build test TESTS)
- -DWITH_AVFFT=ON
- )
- cmake-utils_src_configure
-}
-
-src_test() {
- cd "${BUILD_DIR}" || die
- emake check
-}
-
-src_install() {
- cmake-utils_src_install
-}