summaryrefslogtreecommitdiff
path: root/media-libs/bcg729/bcg729-1.0.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/bcg729/bcg729-1.0.4.ebuild')
-rw-r--r--media-libs/bcg729/bcg729-1.0.4.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/media-libs/bcg729/bcg729-1.0.4.ebuild b/media-libs/bcg729/bcg729-1.0.4.ebuild
new file mode 100644
index 000000000000..703eb5fcb662
--- /dev/null
+++ b/media-libs/bcg729/bcg729-1.0.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools ltprune
+
+DESCRIPTION="encoder and decoder of the ITU G729 Annex A/B speech codec"
+HOMEPAGE="https://github.com/BelledonneCommunications/bcg729"
+SRC_URI="${HOMEPAGE}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~x86"
+IUSE="static-libs"
+RDEPEND="
+ !media-plugins/mediastreamer-bcg729
+"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}