summaryrefslogtreecommitdiff
path: root/media-gfx/word_cloud/word_cloud-1.9.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/word_cloud/word_cloud-1.9.3.ebuild')
-rw-r--r--media-gfx/word_cloud/word_cloud-1.9.3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/media-gfx/word_cloud/word_cloud-1.9.3.ebuild b/media-gfx/word_cloud/word_cloud-1.9.3.ebuild
new file mode 100644
index 000000000000..e945048fb129
--- /dev/null
+++ b/media-gfx/word_cloud/word_cloud-1.9.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9,10,11,12} )
+DISTUTILS_USE_PEP517=setuptools
+DISTUTILS_EXT=1
+
+inherit distutils-r1
+
+DESCRIPTION="A little word cloud generator in Python"
+HOMEPAGE="https://amueller.github.io/word_cloud/"
+SRC_URI="https://github.com/amueller/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ media-fonts/droid"
+
+BDEPEND="dev-python/cython
+ dev-python/setuptools-scm"
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}