summaryrefslogtreecommitdiff
path: root/media-gfx/uniconvertor/uniconvertor-2.0_pre379-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/uniconvertor/uniconvertor-2.0_pre379-r2.ebuild')
-rw-r--r--media-gfx/uniconvertor/uniconvertor-2.0_pre379-r2.ebuild14
1 files changed, 12 insertions, 2 deletions
diff --git a/media-gfx/uniconvertor/uniconvertor-2.0_pre379-r2.ebuild b/media-gfx/uniconvertor/uniconvertor-2.0_pre379-r2.ebuild
index 22552436a69b..2a5d72d35690 100644
--- a/media-gfx/uniconvertor/uniconvertor-2.0_pre379-r2.ebuild
+++ b/media-gfx/uniconvertor/uniconvertor-2.0_pre379-r2.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
PYTHON_COMPAT=( python2_7 )
-inherit distutils-r1 eutils
+inherit distutils-r1 xdg-utils
DESCRIPTION="Convert vector graphic file formats like .cdr, .svg, wmf and more."
HOMEPAGE="https://sk1project.net/modules.php?name=Products&product=uniconvertor"
@@ -61,3 +61,13 @@ python_test() {
cd src/unittests || die
${EPYTHON} all_tests.py || die
}
+
+pkg_postinst() {
+ xdg_mimeinfo_database_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_mimeinfo_database_update
+ xdg_desktop_database_update
+}