summaryrefslogtreecommitdiff
path: root/media-gfx/tif22pnm/tif22pnm-0.14-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/tif22pnm/tif22pnm-0.14-r1.ebuild')
-rw-r--r--media-gfx/tif22pnm/tif22pnm-0.14-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/media-gfx/tif22pnm/tif22pnm-0.14-r1.ebuild b/media-gfx/tif22pnm/tif22pnm-0.14-r1.ebuild
new file mode 100644
index 000000000000..eb2fd906a707
--- /dev/null
+++ b/media-gfx/tif22pnm/tif22pnm-0.14-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="tif22pnm and png22pnm command-line converters"
+HOMEPAGE="http://pts.szit.bme.hu/ https://code.google.com/p/sam2p/"
+SRC_URI="https://sam2p.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ media-libs/libpng:=
+ media-libs/tiff:="
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+ "${FILESDIR}"/${P}-math.patch
+)
+
+src_prepare() {
+ default
+ mv configure.{in,ac} || die
+ eautoreconf
+}
+
+src_install() {
+ dobin png22pnm tif22pnm
+ einstalldocs
+}