summaryrefslogtreecommitdiff
path: root/media-gfx/scrot/scrot-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/scrot/scrot-9999.ebuild')
-rw-r--r--media-gfx/scrot/scrot-9999.ebuild34
1 files changed, 22 insertions, 12 deletions
diff --git a/media-gfx/scrot/scrot-9999.ebuild b/media-gfx/scrot/scrot-9999.ebuild
index 605a004b7102..80d7728667d6 100644
--- a/media-gfx/scrot/scrot-9999.ebuild
+++ b/media-gfx/scrot/scrot-9999.ebuild
@@ -1,19 +1,27 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-inherit autotools bash-completion-r1 git-r3
+EAPI=8
+
+inherit bash-completion-r1
DESCRIPTION="Screen capture utility using imlib2 library"
HOMEPAGE="https://github.com/resurrecting-open-source-projects/scrot"
-EGIT_REPO_URI="https://github.com/resurrecting-open-source-projects/${PN}"
+if [[ ${PV} == *9999* ]] ; then
+ EGIT_REPO_URI="https://github.com/resurrecting-open-source-projects/${PN}"
+ inherit autotools git-r3
+else
+ SRC_URI="https://github.com/resurrecting-open-source-projects/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
LICENSE="feh LGPL-2+"
SLOT="0"
-KEYWORDS=""
RDEPEND="
- >=media-libs/giblib-1.2.3
+ dev-libs/libbsd
+ x11-libs/libXext
x11-libs/libX11
x11-libs/libXcomposite
x11-libs/libXfixes
@@ -28,21 +36,23 @@ DEPEND="
${RDEPEND}
x11-base/xorg-proto
"
+BDEPEND="
+ sys-devel/autoconf-archive
+ virtual/pkgconfig
+"
+
DOCS=(
- AUTHORS ChangeLog CONTRIBUTING.md README.md TODO
+ AUTHORS ChangeLog README.md
)
src_prepare() {
- sed -i -e 's#-g -O3##g' src/Makefile.am || die
- cat "${FILESDIR}"/ax_prefix_config_h.m4 >> acinclude.m4 || die
-
default
- eautoreconf
+ [[ ${PV} == *9999* ]] && eautoreconf
}
src_install() {
default
- newbashcomp "${FILESDIR}"/${PN}-1.2.bash-completion ${PN}
+ newbashcomp "${FILESDIR}"/${PN}-1.7.bash-completion ${PN}
}