summaryrefslogtreecommitdiff
path: root/media-gfx/scour/scour-0.38.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/scour/scour-0.38.2-r1.ebuild')
-rw-r--r--media-gfx/scour/scour-0.38.2-r1.ebuild19
1 files changed, 14 insertions, 5 deletions
diff --git a/media-gfx/scour/scour-0.38.2-r1.ebuild b/media-gfx/scour/scour-0.38.2-r1.ebuild
index 30d85af79f5f..8809aac2f3c1 100644
--- a/media-gfx/scour/scour-0.38.2-r1.ebuild
+++ b/media-gfx/scour/scour-0.38.2-r1.ebuild
@@ -1,21 +1,30 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
+
inherit distutils-r1
DESCRIPTION="Take an SVG file and produce a cleaner and more concise file"
-HOMEPAGE="https://github.com/scour-project/scour"
-SRC_URI="https://github.com/scour-project/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="
+ https://github.com/scour-project/scour/
+ https://pypi.org/project/scour/
+"
+SRC_URI="
+ https://github.com/scour-project/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 ~sparc x86"
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+"
python_test() {
"${EPYTHON}" test_scour.py -v || die "Tests fail with ${EPYTHON}"