summaryrefslogtreecommitdiff
path: root/media-gfx/rawtherapee/rawtherapee-5.8-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/rawtherapee/rawtherapee-5.8-r1.ebuild')
-rw-r--r--media-gfx/rawtherapee/rawtherapee-5.8-r1.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/media-gfx/rawtherapee/rawtherapee-5.8-r1.ebuild b/media-gfx/rawtherapee/rawtherapee-5.8-r1.ebuild
index ea59ec8cbd19..6bc9d3808b2d 100644
--- a/media-gfx/rawtherapee/rawtherapee-5.8-r1.ebuild
+++ b/media-gfx/rawtherapee/rawtherapee-5.8-r1.ebuild
@@ -47,9 +47,11 @@ PATCHES=(
)
pkg_pretend() {
- if use openmp ; then
- tc-has-openmp || die "Please switch to an openmp compatible compiler"
- fi
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
src_configure() {