summaryrefslogtreecommitdiff
path: root/media-gfx/potrace/potrace-1.16.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/potrace/potrace-1.16.ebuild')
-rw-r--r--media-gfx/potrace/potrace-1.16.ebuild14
1 files changed, 10 insertions, 4 deletions
diff --git a/media-gfx/potrace/potrace-1.16.ebuild b/media-gfx/potrace/potrace-1.16.ebuild
index 61be1a6b5914..b4da07394f6f 100644
--- a/media-gfx/potrace/potrace-1.16.ebuild
+++ b/media-gfx/potrace/potrace-1.16.ebuild
@@ -11,8 +11,8 @@ SRC_URI="http://potrace.sourceforge.net/download/${PV}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
-IUSE="metric static-libs"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="metric"
RDEPEND="sys-libs/zlib:="
DEPEND="${RDEPEND}"
@@ -22,12 +22,18 @@ DOCS=( AUTHORS ChangeLog NEWS README )
src_configure() {
tc-export CC # bug 610098
local myeconfargs=(
- --enable-shared
+ --disable-static
--enable-zlib
--with-libpotrace
$(use_enable metric a4)
$(use_enable metric)
- $(use_enable static-libs static)
)
econf "${myeconfargs[@]}"
}
+
+src_install() {
+ default
+
+ # no static archives
+ find "${ED}" -name '*.la' -delete || die
+}