summaryrefslogtreecommitdiff
path: root/media-gfx/phototonic/phototonic-2.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/phototonic/phototonic-2.1.ebuild')
-rw-r--r--media-gfx/phototonic/phototonic-2.1.ebuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/media-gfx/phototonic/phototonic-2.1.ebuild b/media-gfx/phototonic/phototonic-2.1.ebuild
index 46087619b847..bb861a81715c 100644
--- a/media-gfx/phototonic/phototonic-2.1.ebuild
+++ b/media-gfx/phototonic/phototonic-2.1.ebuild
@@ -1,12 +1,13 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit gnome2-utils qmake-utils xdg-utils
+inherit qmake-utils xdg-utils
DESCRIPTION="Image viewer and organizer"
HOMEPAGE="https://github.com/oferkv/phototonic"
+
if [[ ${PV} = *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/oferkv/phototonic.git"
@@ -20,9 +21,9 @@ SLOT="0"
IUSE="svg tiff"
RDEPEND="
- dev-qt/qtwidgets:5
- dev-qt/qtgui:5
dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
media-gfx/exiv2:=
svg? ( dev-qt/qtsvg:5 )
tiff? ( dev-qt/qtimageformats:5 )
@@ -38,11 +39,11 @@ src_install() {
}
pkg_postinst() {
- gnome2_icon_cache_update
+ xdg_icon_cache_update
xdg_desktop_database_update
}
pkg_postrm() {
- gnome2_icon_cache_update
+ xdg_icon_cache_update
xdg_desktop_database_update
}