summaryrefslogtreecommitdiff
path: root/media-gfx/openvdb/openvdb-11.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/openvdb/openvdb-11.0.0.ebuild')
-rw-r--r--media-gfx/openvdb/openvdb-11.0.0.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/media-gfx/openvdb/openvdb-11.0.0.ebuild b/media-gfx/openvdb/openvdb-11.0.0.ebuild
index 35a71fe06c64..ff01eb449a31 100644
--- a/media-gfx/openvdb/openvdb-11.0.0.ebuild
+++ b/media-gfx/openvdb/openvdb-11.0.0.ebuild
@@ -175,21 +175,22 @@ src_prepare() {
}
my_src_configure() {
- local version
+ local version abi_version
version=$(ver_cut 1)
+ abi_version="${version}"
if use "abi$(( version + 1 ))-compat"; then
- version=$(( version + 1 ))
+ abi_version=$(( version + 1 ))
elif use "abi$(( version - 1 ))-compat"; then
- version=$(( version - 1 ))
+ abi_version=$(( version - 1 ))
elif use "abi$(( version - 2 ))-compat"; then
- version=$(( version - 2 ))
+ abi_version=$(( version - 2 ))
fi
local mycmakeargs=(
-DCMAKE_FIND_PACKAGE_PREFER_CONFIG="yes"
-DCMAKE_INSTALL_DOCDIR="share/doc/${PF}/"
- -DOPENVDB_ABI_VERSION_NUMBER="${version}"
+ -DOPENVDB_ABI_VERSION_NUMBER="${abi_version}"
-DOPENVDB_BUILD_DOCS="$(usex doc)"
-DOPENVDB_BUILD_UNITTESTS="$(usex test)"
-DOPENVDB_BUILD_VDB_LOD="$(usex utils)"